Unable to do a bench update

Hi ,
I tried doin a bench update which results in the following.

remote: Enumerating objects: 3552, done.
remote: Counting objects: 100% (2279/2279), done.
remote: Compressing objects: 100% (778/778), done.
remote: Total 1972 (delta 1547), reused 1596 (delta 1192), pack-reused 0
Receiving objects: 100% (1972/1972), 258.57 KiB | 704.00 KiB/s, done.
Resolving deltas: 100% (1547/1547), completed with 194 local objects.
From GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript
3dd424b87…d831ba085 develop → upstream/develop
Backing up sites…
Please specify --site sitename
INFO: A newer version of bench is available: 5.0.0 → 5.1.0.
Any help would be appreciated.

This may give you clues

I tried reinstalling the way they’ve mentioned.But the issue still persists.
bench update results in :
Backing up sites…
Please specify --site sitename

Hi @rajatkhandeparkar

‘sitename’ is a placeholder here that refers to the actual name of your site - for example ‘site1.local’ is the default name that is assigned.

So what your sitename is, you must identify in your case.

Yess i got that.
bench --site site.sts --force reinstall
and then:
bench --site site.sts install-app erpnext

But it still wouldn’t work.

Perhaps set that as the default site bench use site.sts

Yes Sir ,
Done that.
bench update still not happening.

never heard of this but would …

bench --site [site_name] update

… be something worth trying?

But no luck.No such command.