Updating issue v10.1.42 to v10.1.43

I was confuse about this version i tried to update this but seems error has occured…
Is anyone knows how to fix this :frowning: :disappointed_relieved:

INFO:bench.utils:updating bench
INFO:bench.utils:git pull
error: cannot open .git/FETCH_HEAD: Permission denied
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/cli.py”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/bench-repo/bench/commands/update.py”, line 36, in update
File “/home/frappe/bench-repo/bench/utils.py”, line 261, in update_bench
exec_cmd(“git pull”, cwd=cwd)
File “/home/frappe/bench-repo/bench/utils.py”, line 159, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull

you probably don’t have permissions on it. giving your user permissions on this will help.

where is your bench folder located ?

this is the folder where my bench folder is located /home/frappe/bench-repo

No I meant the frappe-bench folder but that is okay.

I found this link and this particular answer :

So if you can use the commands mentioned on this answer and provide your user permissions on the folders frappe-bench, erpnext and frappe your problem should be solved.

See some examples of chown command usage and you should be able to do it.

i tried it but it wont work

you tried this (assuming your linux user is cpsolution)

chown -R cpsolution:cpsolution /home/frappe/frappe-bench/apps/frappe

but this didn’t work ?

i tried it but still dont work…

try this one

chown -R frappe:frappe /home/

Thanks it works