Upgrade from erpnext 7 to 8 on Virtualbox VM failing

I have downloaded the vm from website. and want to upgarde it to latest version with gst but once I run bench update and then bench update --upgrade it fails with long list of errors

I have tried the following solutions
sudo chown -R frappe:frappe /home/frappe/.bench
sudo chown -R frappe:frappe /home/frappe/frappe-bench
cd /home/frappe/.bench
git reset --hard
git pull
cd /home/frappe/frappe-bench
bench update

I even hard reset the git in apps and frappe folder but I could not find the .bench directory in the vm

With regards
Deepak Kashyap


My steps worked in a month ago:

Hope this helps.

Hi Deepak!
Let me know if this works for you. I’m facing same issue as yours

The bench repo could also be on /home/frappe/bench-repo on older installs.

I am trying the solution in first post will post feedback

When I run
bench update --upgrade / supervisor error
I get error

Error: Got unexpected extra arguments (/ supervisor error)

Now I have come back to this point after I ran bench update --upgrade
bench.utils.CommandFailedError: npm install

I have upgarded the nodej as per instructions here and ran bench upgrade but still it fails

sudo npm cache clean -f
sudo npm install -g n
sudo n stable
sudo ln -sf /usr/local/n/versions/node//bin/node /usr/bin/node

The Reset Git
cd /home/frappe/bench-repo
git reset --hard
git pull
cd /home/frappe/frappe-bench/apps/erpnext
git reset --hard
git pull
cd /home/frappe/frappe-bench/apps/frappe
git reset --hard
git pull

bench update --upgrade

Now I am getting only a screen with Home & Login links but no login text box

Finally Got it Working after running
bench clear-cache

1 Like

Nice work keep up!

This subject should be closed…

Ok now though I logged in and the setup asked the question the frapper cup is chaking for all the while
It doesn;t take that long usually

When I inpect the page I saw this error
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

Ok this too Solved
bench update --build
bench migrate

It Cannot Save the Data Yet!

It is V8 by now:

Plese close this subject.