V9_latest pull request update needs reset everytime

In the latest version V9, every time taking latest updates then it is asking for the bench update --reset. So whenever any new changes made or any pull needs to be taken then these commands need to be made.Earlier when there is bench update command fire then automatically update and latest pull comes but now need to use bench update --reset on every pull.

kindly assist to this issue on the latest. Below is the screenshot for the reference use.


No one else is reporting this. Are you doing some changes to your frappe app?


No, I am getting this error every time on latest pull… Even my colleague is facing this issue.

Are you using a different user for pulling changes?


may be you should git reset:

Reset Git
cd /home/frappe/bench-repo
git reset --hard
git pull
cd /home/frappe/frappe-bench/apps/erpnext
git reset --hard
git pull
cd /home/frappe/frappe-bench/apps/frappe
git reset --hard
git pull

After it in the bench directory:
bench update

Hope this helps.


I am also suffering from this issue. And I also reported about this issue earlier.

I am logging with the same user as root and I am still proceeding with the same error. So please refer this link for more clarification on this matter, Also I am attaching the screenshot for the current user as I am logged in.


I also have this issue.

@mohnish_thakur2003 @Chandresh_Thakkar @bardbq

You all seem to be devs here. Since you are having this problem, try getting into the bottom of it and find the solution.

There is no rocket science, its only git and some Linux file permissions.

Please try and debug and post a solution!

I had a permission error that prevented me to perform the latest hotfix update after I upgraded from v8 to v9. I was able to fix the permission issue using:

ubuntu@ip-xxx-xx-xx-xx:~$ cd /home/frappe/frappe-bench/apps/erpnext
ubuntu@ip-xxx-xx-xx-xx:/home/frappe/frappe-bench/apps/erpnext$ sudo chown -R frappe:frappe “$(git rev-parse --show-toplevel)/.git”
ubuntu@ip-xxx-xx-xx-xx:/home/frappe/frappe-bench/apps/erpnext$ cd /home/frappe/frappe-bench/apps/frappe
ubuntu@ip-xxx-xx-xx-xx:/home/frappe/frappe-bench/apps/frappe$ sudo chown -R frappe:frappe “$(git rev-parse --show-toplevel)/.git”
ubuntu@ip-xxx-xx-xx-xx:/home/frappe/frappe-bench/apps/frappe$ cd /home/frappe/frappe-bench
ubuntu@ip-xxx-xx-xx-xx:/home/frappe/frappe-bench$ su frappe
Password: xxxxxxx
frappe@ip-xxx-xx-xx-xx:~/frappe-bench$ bench update --reset

the sudo chown -R frappe:frappe “$(git rev-parse --show-toplevel)/.git” command performed in erpnext and frappe git repository has fixed the permission issue (still no idea why I had this permission problem after updating) and I was then able to update.

Maybe that could help with the bench update issue.


1 Like

Weird. Did you update earlier via root? Which was the owner before your changed the owner to frappe, maybe that will give you a clue.

Yeah, that’s weird because no, I ALWAYS make sure I’m using user frappe when doing updates… The root (ubuntu) user is always the default user when I ssh into my Amazon AWS instance (can’t connect using the private key with any other user other than “ubuntu”), I then switch to frappe user to perform any action related to frappe/erpnext.