What is the Mysql default password?

nope, there’s nothing in /root. I am using ubuntu 14.04 LTS desktop.

When I run these commands

wget https://raw.githubusercontent.com/frappe/bench/develop/playbooks/install.py1
python install.py --develop

does it actually install mysql or mariadb? or should I install separately?


This is the raw / beta version in development mode and is full of buggy nets and I don’t recommend it unless for nerdy developers who knows there away around the system…

If your not then use the easy install script :

You can use it in develop mode which is less buggy the the beta version…

So did you mean this one which can be used for development?

wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh --bench-branch develop

Do i have to install mysql/mariadb separately or the above script will auto install for me?


I mean this one:
wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh --setup-production

And yes it setups everything for you from a-z

I tried that before, but I wasn’t able to enable developer_mode: 1


i want to learn how to build my own modules

Just install this one and will help you throw the development mode me and everyone else :slight_smile:

1 Like

While running bench new-site library command, it asks for MySql root password.
I tried with frappe and it worked…

For ERPNext VM mysql root password is frappe. If you install ERPNext via easy install script then you will find admin and mysql root password in frappe_passwords.txt

1 Like

Thanks It’s woks

I have ERPNext VM and the mysql root password is frappe.

Thanks again

I am facing the same issue with MySQL root password being wrong on my Mac.

  1. I tried entering frappe as suggested in the first post.
  2. I could not find any frappe_passwords.txt in the directory where I installed frappe_bench using bench init frappe_branch
  3. I could not find any frappe_password.txt in the user root folder ~
  4. I tried entering empty password and my system sudo password

but nothing worked. can someone please help me?

See if there is a passwords.txt file just outside the bench directory.

I tried in the parent directory also, but nothing is present…

Just to record what I have done for the benefit of someone else who might face the same challenge…

Then I tried to set password as per the idea in this thread

  • mysqladmin -u root -p password 'frappe'

sql - MySQL set root password wrong - Stack Overflow
sql - MySQL set root password wrong - Stack Overflow

  • then tried bench new-site library.test and it was working, but a different error
    ERROR 2002 (HY000): Can’t connect to MySQL server on ‘’ (60)
    Table ‘tabDefaultValue’ missing in the restored site. Database not installed correctly, this can due to lack of permission, or that the database name exists. Check your mysql root password, validity of the backup file or use --force to reinstall
  • Then i tried again bench new-site library.test
  • and got another error
    in setup_database
    raise Exception(f"Database {db_name} already exists")
    Exception: Database _e12f97fbea49690f already exists

I did not know why this error comes.
In the end, I gave up trying to install Frappe on my own on Mac.

Hi there,

Your MariaDB root password is not set by Frappe, and Frappe has no access to it.

If you installed via homebrew, I believe that there is no password set by default. Depending on your version, you might be able to set it using mysql_secure_installation. If that doesn’t work, you’ll have to investigate how to set/reset mariadb’s root password.

1 Like

try “password”

Thanks for the response. As of now, I have uninstalled the entire frappe setup, as I am trying it out through Docker. I will consider this utility if I came back to manual installation again.

Finally I got MariaDB installation working on MacOS Big Sur - thank God!

after a lot of time reading through many articles and not succeeding, I decided to read the code for the brew Formula for mariadb to see what it does - It sets an empty password. But then mysql_secure_installation does not accept when I press enter without entering any password. So, I changed the Ruby code to set a password and then reinstalled mariadb and restarted the services. Then I ran mysql secure installation and the password I set in the Ruby code worked. If anyone faces the same issue in Mac, I can offer detailed instructions as I have taken screenshots of the steps and issues faced in my notes app.

MariaDB Knowledge Base


Please , could you provide the detailed instructions for MacOS Silicon chip. I am having the same issue , no where to get the default password of MySql. ‘Blank’ does not work. Please , provide screenshots as well.

I believe if you sudo mysql and enter any password, it would let you in :slight_smile:

Would you be able to provide screenshots? Thank you!