Wizard won't finish

i have a similar problem when i choose south africa it freezes
this was reported but looks like the developers not really interested in fixing

Yes. In the SQL table “tabDefaultValue”, there is a setting named ‘desktop:home_page’

  • Before the wizard completes, the value is “setup-wizard”
  • After the wizard completes, the value is “desktop”

ERPNext examines the value, to determine whether the Wizard or Desktop should be displayed, when you navigate to the site.

Here’s the SQL query for that.

SELECT defvalue, defkey, parentfield
FROM <your_database_name>.tabDefaultValue
defkey = 'desktop:home_page';

-- defvalue is either 'setup-wizard' or 'desktop'

There should be an API for the wizard. You should be able to install ERPNext, and transmit JSON data containing answers to all the wizard’s questions.

No idea if that is actually implemented, though.

Thanks for the SQL.

Are there operations performed by the Wizard that cannot be done by Administrator or using Bench?

Also, do you know if the ErpNext pay by the month service, permits SQL access? API access?

Bench definitely cannot do it (yet). If there are Administrator tasks for such a thing, I’ve never seen them.

I have no knowledge of Frappe’s hosting services, and what they allow clients to do.

This issue has been a problem for long. I think it’s time to fix it once and for all.

There are a few small patterns that we have identified. However they cannot be attributed to the failure as a whole yet.

@MartinHBramwell can you tell me the specifications of the machine you’re installing ERPNext on? Also the versions you’re installing

I recall revant_one suggested this workaround awhile back [Mar-2017] Showing there were error during setup ERPNext - #19 by revant_one

@clarkej - Thanks, John…that appears to be a good workaround. With a small effort, should be able to make a Bench CLI command that does that.

@scmmishra - I’ve seen nothing that indicates OS or version makes any difference. Bug has existed since at least version 7. That being said. I know for a fact it’s happened on a freshly-installed Ubuntu 18.04 with ERPNext version 12. You can start there, if you want to experiment.

Hey Clarke,

That link is hugely helpful.

Ultimately I’m going to go with this genius recommendation from that thread:

Meanwhile this is kind of a “WTF” for me:


I would like to use the setup_complete(args) RPC that @revant_one suggested, but I would need all those different data points to be documented. Is that available somewhere?

FYI, I completed a clean install this morning. Ubuntu 18.10, ERPNext version 12. No errors during installation. No errors upon bench_start

Logged into http://localhost:8000, and completed the Setup Wizard.

First Attempt: Wizard failed for no apparent reason. Gave me option to “Retry”. So I clicked that.

Second Attempt: Wizard appeared to be working. The progress bar never moved. But my CPU was being utilized. So I patiently waited. Eventually, I was told the installation completed. However…my new user didn’t have access to DocTypes, and my browser refused to show any pages. Refreshing did not work. Browser page totally frozen.

Third Attempt: Closed my browser completely, and re-opening to http://localhost:8000. Was allowed to login as Administrator.

Setup Wizard is still unreliable, broken, and only succeeds intermittently. Needs Rework.

Another day. Another ERPNext installation. This time for one of my clients. Ubuntu 18.04, ERPNext v12.3. Browser used was Opera.

No errors this time. The Wizard took a long time to complete. 4+ minutes. During this time the progress bar never moved a micron. I thought about giving up, but just kept starting at the screen, and the terminal where Bench was running. Then it finally refreshed, and took me straight to Desk.

Why better today than yesterday? Who knows.

Done testing Bench installations for a while; have other ERPNext issues to solve first.

To be honest i am wondering why you guys are facing this wizard issue. I have tested on cloud VPS, bare metal local pc and virtual pc (virtualbox, vmware and Hyper-V) and in all cases, wizard completed without issues after fixing the do not panic error after easy install. I couldn’t reproduce this wizard error.

Yesterday I spent the early morning with an ErpNext 14-days trial account, and all the rest of the day with a virtual machine and the Bitnami installer.

I was trying to find any other way to get the Wizard to work once, JUST ONCE, so I could back up the database and have it available to restore where I want it.

The trial account uses a different Wizard (is anyone surprised). It asked most, but not all of the questions of the publicly available Wizard. When I ran the backup I discovered that for the trial version the database archive is not included in the bundle (is anyone surprised).

So that was yet another dead end. On to Bitnami…

After figuring out how to workaround the defects in their installer (accepting that it set up mail services corrupts site-config.json) I found that it filled in some, but not all, of the Wizard stuff automatically, and worked ok, but did not set it up with what I wanted.

I ran bench drop-site then bench new-site and subsequent commands, and got to a clean Wizard.

After that, my experience was then the same as @brian_pond experienced yesterday: Wizard won't finish - #15 by brian_pond

… but then my second attempt, was like his third…

So I do now, at last, have a way to get a prepared database to work from.

I cannot explain why I had no problems with this 'til 10 days ago, then always problems with it since then. Nor can I explain why some people see it and not others.

The good news is I got some personal assistance from the founder @rmehta!! Yes!

He corrected the title of one of my posts to read “Is there any way at all to configure ERPNext without using the Wizard?” instead of “Is there any way at all to configure ErpNext without using the Wizard?”

It’s nice to see that he’s concerned about 10 days of my life down the toilet on a 3 year old unresolved defect.


@MartinHBramwell Lol this is funny but a good spin. I hope you find a way to get around the issue you’re facing because i have tried on different hosting platforms to replicate your issue but each time my wizard completes without any errors (maybe the wizard recognizes my noobiness and decided to conform :man_shrugging:).

1 Like

This difficulty of replicating the issue is why I tried the Bitnami route.

The only similarity to my previous attempts is in the host, an Ubuntu 18.04 LTS VM running in Xen running in Apache Cloudstack.

If someone wanted to give it a try, I’d spin up a copy and give them the root password.

We wonder that too.

I don’t think it’s funny. I think it’s sad, actually.

Eventually, if you keep trying again and again, the wizard works.

Martin and I aren’t the only people to experience this issue. There have been dozens over the past 3 years. Searching the forums, you can see the old posts.

However. After you successfully install ERPNext from scratch and get it working, how often does a normal person repeat the process again? Probably not often. Because once it’s running, you want to use it. That was the whole point of installing in the first place.

So the people seeing this problem are mostly first-time users (or consultants who install ERPNext for a living).

But the bug is intermittent. It doesn’t always happen.

And those are the worst bugs to resolve.

Just for the records, we ALWAYS have this problem. In this version and in the previous ones.

1 Like

For me this is reproducible 100% of times, and unlike Brian, a loooong wait doesn’t solve it.

Simply spin up the downloadable VM with a brand new ERPNext and start the Wizard - then choose as Country “South Africa” and GMT+2 (Pretoria/Harare) as the timezone. The wizard swill never finish.

2 Notes:
1 - I’m still using v11, did not move to 12 yet, perhaps it works better?
2 - If I choose “Botswana” in stead of South Africa, it works, which makes me think a previous mention of the culprit possibly being in the timezone/UoM or some localization settings might be on to something.

Currently, every Demo I do for a prospective ERPNext company I have to do this trickery of first picking Botswana, finishing the Wizard, then rectifying all the Botswana settings back to S.A. settings in setup, explaining to the client that it’s a temporary wizard deficiency only and won’t affect the actual system use.

It’s highly irritating though, I wish it wouldn’t.



A broken Wizzard sucks. So nobody want to start with a broken Software from the beginning.

It seems it works for the developers, but not for newcomers.

Until the developers reach out to someone who is blocked by the broken Wizard, get permission to look into their server and figure out the cause, nothing will change.

If it was my product that’s what I would do.

If asked I would be pleased to have them look around my disposable virtual machine.

It depends on someone giving a shit, doesn’t it?


If you install on google cloud, there is no problem.

If you install on local computer, especially using virtualbox, I always encounter this.
All I do is retry, or open the site at the browser and repeat the setup process. It eventually goes through. If you are on develop mode, you will see the logs on the console that the setup somehow reaches a new stopping point as you retry. (On production mode, you can also see this in the logs.) This has something to do with how powerful the computer you are using, I think.