"Your system is being updated. Please refresh again after a few moments" after running bench migrate

It worked.

2 Likes

At least is helps to continue working on other things while the patches failing are fixed

To check and change that setting from the bench, do this:

bench set-config maintenance_mode 0

frappe@ubuntu:~/frappe-bench$ bench show-config | grep maintenance_mode
maintenance_mode 0
frappe@ubuntu:~/frappe-bench$ bench set-config maintenance_mode 1
frappe@ubuntu:~/frappe-bench$ bench show-config | grep maintenance_mode
maintenance_mode 1

4 Likes

@Mukane_Onesimas Thank you for your answer. It’s work for me. But each I do an update “maintenance mode.”: move back to 1. I have to set it manually each in order to start my site.
But no matter what I do “bench update”, here is the message output in terminal:

Cannot proceed with update: You have local changes in app “frappe” that are not committed.

Here are your choices:

  1. Merge the frappe app manually with “git pull” / “git pull --rebase” and fix conflicts.
  2. Temporarily remove your changes with “git stash” or discard them completely
    with “bench update --reset” or for individual repositries “git reset --hard”
  3. If your changes are helpful for others, send in a pull request via GitHub and
    wait for them to be merged in the core.

So I just want to know finally if bench update should behave like that.

bench set-config maintenance_mode 0

This is just for per site config.

This is very simple, after i had struggled for hours in the night i simply edited the common_site_config.json

And this mentioned by @Mukane_Onesimas is the config for all sites.

Both configs have maintenance_mode so better check both files.

1 Like

cd ~/frappe-bench/apps/frappe && git stash
cd …/… && bench update

Disable maintenance mode by : bench set-config maintenance_mode 0

4 Likes
3 Likes

Thanks!! this work…

Encountered this problem will try the maintenance mode changes.
when this problem occured ping to the instance is Timing Out

first do “bench --site {site name} migrate”. then if you see any error make sure to solve the error that you got(it might be installing a module or do other thing) then set maintenance mode off otherwise it will not work

It worked for me too.
Thank you…