404 error after dns_multitenant activated

Hello community,
I relative new to erpnext.
The system runs until this moment but now i want to install a ssl-certificate.
Following steps I have done:
install frappe+erpnext according to these instructions:
[[Tutorial] How to 'manually' install ERPNext v13.11 Production on Debian 10 (w/SSL cert)]

I’m running following versions:
erpnext 13.18.0
frappe 13.18.0

Afer bench config dns_multitenant onand bench setup add-domain --site site1.local [your.new.URL] I have my domain in the config file but when I reload the nginx config with bench setup nginx I don’t see any port and can’t connect to the website in the browser.
There I get a 404 error.

When I set dns_multitenant off and reload nginx config I can access the site normally.

That I make false or do you have any tips?

Many thanks for your help.

It appears you may have skipped a step.

Before you run the bench setup nginx command, you need to run the following:

bench setup add-domain --site site1.local [your.site.URL]

This creates the site name that connects to the site1.local site directory. Then you must go to your URL provider and use their DNS tool to create the pointers for your new site to your servers IP Address.

Once those steps are done, you can successfully create a security certificate for the site.

Hope this helps…


Thanks for your help.
My dns setting wasn’t correct.
Now it works fantastic with a ssl-certificate.