404 error Not Found

I wanted to copy an existing and working installation. The existing setup runs in a virtual machine.

  1. I copied the VM file and setup a new VM
  2. I successfully could start up ERPNext and access the copy. However, as that seed VM already had transactions and data, I first tried to delete the transactions. However I could not modify the existing company (and the chart of accounts, etc.)
  3. So I decided to install a new site with bench new-site new-domain
  4. I deleted the old site with bench drop-site old-domain
  5. To make the new site default, I tried bench use new-domain
  6. I first fiddled manually with config/nginx.conf but later discovered bench setup nginx
  7. After countless bench restart, bench migrate and other tries, I can’t access the ERPNext site. All I get is
Not Found
old-domain does not exist

What am I missing? How can I point it to the new domain?

Ubuntu 22.04.4 LTS
erpnext 15.29.3
frappe 15.34.0
payments 0.0.1
webshop 0.0.1

I guess I just figured it out. It looks like node was defaulting to an older version. So after a

nvm alias default 18.20.4

it worked just fine.