404 page not found when installing using docker-compose

I am trying to install erpnext using docker-compose for almost 3 hours now on a 32 gb ram, 8 vcors, 640 gb storage. 18.04 LTS digital ocean droplet but no luck at all
i’m following the exact interactions as mentioned in Single bench but when I go to erp.domain.com it gives me 404 page not found
I think its an SSL issue? because when I did curl https://erp.domain.com it returns: The certificate chain was issued by an authority that is not trusted.
I have accessed nginx container and tried to locate default file in site-available but I couldn’t find the directory at all, nothing useful so far.
couldn’t access traefik container to investigate, when I try docker exec -it <container_id> bash it return bash not found error.

now I will try to reinstall it using a bit older version, the issue could be because I used ERPNEXT_VERSION=edge and FRAPPE_VERSION=edge

bellow is the env-production file for reference, docker-compose.yml file is the same as in github, no changes

LETSENCRYPT_EMAIL=email@example.com ERPNEXT_VERSION=edge FRAPPE_VERSION=edge MARIADB_HOST=mariadb MYSQL_ROOT_PASSWORD=mysqlpass SITE_NAME=erp.mywebdomain.com SITES=erp.localhost DB_ROOT_USER=root ADMIN_PASSWORD=myadminpass INSTALL_APPS=erpnext ENTRYPOINT_LABEL=traefik.http.routers.erpnext-nginx.entrypoints=websecure CERT_RESOLVER_LABEL=traefik.http.routers.erpnext-nginx.tls.certresolver=myresolver HTTPS_REDIRECT_RULE_LABEL=traefik.http.routers.http-catchall.rule=hostregexp({host:.+}) HTTPS_REDIRECT_ENTRYPOINT_LABEL=traefik.http.routers.http-catchall.entrypoints=web HTTPS_REDIRECT_MIDDLEWARE_LABEL=traefik.http.routers.http-catchall.middlewares=redirect-to-https HTTPS_USE_REDIRECT_MIDDLEWARE_LABEL=traefik.http.middlewares.redirect-to-https.redirectscheme.scheme=https

Last Travisci cron was successful,

I’ve not yet tried to replicate it on digitalocean.

Also, I observed SITE_NAME variable and SITES variable have different site names, it should be:


Thanks @revant_one for taking the time to help me, edited as per your instructions.
After taking a closer look at the env-production file I noticed that CERT_RESOLVER_LABEL=traefik.http.routers.erpnext-nginx.tls.certresolver=myresolver
Should it remain like that? I have no idea what myresolver is or what to get it from, maybe that is another factor for the issue?
Waiting for your advise if possible

Tried and succeed to get it to work, your solution solved the problem.
You are welcomed to test it on my digital ocean droplet as I will reinstall it one more time before product.
just pm me