Accessing ERPNext from another PC on a network

I have installed ERPNext develop on a VM on a windows server 16 and i can access it from the localhost with localhost:8000 but I can’t access it from another PC on a network using the IP address i found by using the command ifconfig, inet addr: , and changed the network of the VM from NAT to bridged adapter but sill can’t access ERPNext.

how can i access it please give me some ideas.
Thank you.

You would need to point the browser on the other PC(s) (which must be on the same 10.0.2.x LAN) to
Also make sure that you open any firewall blocks to that port


You can access the VM indirectly. Firstly, Check if SSH is working on both the systems. If both are up and accessible, You can access the VM of Host Machine by the following command. Make sure both systems are in the same network

ssh -p [port_no] user_name@ip_address (ssh -p 22 rohan@

After that, you can have full control of that system. Now you can manually SSH into the Virtual Machine using the following command

ssh -p [port_no] frappe@localhost (ssh -p 3022 frappe@localhost

Now, you’re nearly done. You just have to access the erpnext site by entering the machine’s IP address followed by port number i.e.

Your site is up and running and you can access from another computer.

I hope you find this useful.


Sorry For the delayed replay but i tried and i still couldn’t access it

i am using windows on the other PC’s and to use ssh i think i need “PuTTY” to access it. Also the VM with the ERPNext is installed on a windows server 2016.

Is there any other way that i can use ?

i tried this command in my Windows command prompt
ssh -p [port_no] user_name@ip_address (ssh -p 22 rohan@

and now i am getting an error saying
ssh: connect to host port 22: Connection timed out

how can i fix this??

This may happen because your windows server is no different port " port 22" is the standard port.
so to check which port windows server is using please try ` netstat -a -on command prompt.
And then replace that port with 22

I hope you find this useful.

1 Like

Thank you so much Its working now.

Hey there, can anyone help me with this !

I have a VM setup on my server running Ubuntu 16 lts on Oracle Virtual Box. I have erpnext setup with dns multitenant on.

I have successfully setup my Erpnext with a domain name accessible from internet. I had pointed the dns from godaddy to my router ip and port forward to ubuntu vm within router. it works fine.

Problem is I am unable to accesss erpnext site within the LAN. it gets routed to my router page if I access it via domain name. Also not accessible via local IP address,( dns multitenant on).

I also tried adding ip address & domain name on /etc/hosts file, no success !

how do i access erpnext website locally ? please help

did you specify port 80 in your forwarding rule?

Yeah. I am able to access my erpnext site on the internet.
The problem is i am unable to access it on the LAN.
I have dns multitenant on and ssl cetificate installed

Unable to access it via ip or domain name

Perhaps your VirtualBox is set to NAT network and you are better off with a bridged network?

my VM is already set to bridged.

Which IP the client has ?
Have you checked the Windows-Firewall-Setting on the 2016er Server ?

Are you in the same domain ? Have you checked the port-settings (inbound) in the firewall-settings of the server ?

The ip address is lan and not wan side of your network?

So that ip address works for ssh access to the server but not http client access?

I have my erpnext server up & running, it is accessible via a domain name over internet, i have also setup ssl certificate on the same. but when I try to access the server via domain name over LAN it jumps to my router page.

I need to access over LAN.

Once again. Which IPs you have on the LAN-Interface of ther Server and which on the Client ?

On your PC your DNS-Server seems to be the public one (probably comming from your DHCP-Server). So it points to your WAN-Interface. If you will access the LAN-Interface of your Server you have to access it by IP instead of the Domain-Name. The other way is (if you have an internal DNS-Server inside your network) place an entry with your server.domain with the LAN IP. If you do not have an internal DNS, add an entry to your local host table of your client PC.

look my vm is running on bridged setting having a static IP of with gateway & dns & client pc has ip

I have dns entry to point to my public IP. I am able to access my erpnext instance over the net for example.

When i try to access it from the pc having VM, it points to my router, and if i try to access it from ip address of my server i.e it show bench error page sorry we will be back soon, because of dns multitenant on.

I added public ip & domain name on both client & server host file, but no success either.

can u help ?