Accounting reports won't run

I am in the process of setting up ERPNext using the Docker images. I’ve done the basic setup and followed the instructions below in the documentation to load beginning balances for Stock, Fixed Assets, Capital Accounts, and Liabilities.

Opening Balance in Accounts

I have tried to run the General Ledger, Balance Sheet, Profit and loss, and Trial balance reports to confirm everything looks correct. No matter what I do, none of them will run. They just sit at the initial screen with “Loading…” in the middle.

I’ve tried:

  • Selecting the finance book
  • Changing the fiscal year
  • Selecting various other options available in each report
  • Clicking the refresh button in the top right corner.
  • Forcing reload of the page.

I am not sure what to do next. There are no error logs and I can see the Fixed Assets and initial stock I loaded per the documentation. The profit and loss graph on the dashboard shows values as expected as well.

I can run the Stock Ledger and get the expected data returned, so some reports are working.

Any help would be appreciated.