Adding Ubuntu 16.04 Support: Getting the same error

Continuing the discussion from Adding Ubuntu 16.04 Support:

I am also getting the same error

Developers please make the bench compatible with Ubuntu 16.04 LTS .

Hey @nagarajan @ragav sorry for the troubles. We’re still working on the new script, because the old one is going to be deprecated, and you can expect a release within a week’s time.

Do you plan to do the Development setup?

Hi @vjFaLk

Yes we planned for the development setup but getting the same.

@nagarajan @ragav

From 16.04 onwards MariaDB has changed its GPG signing key because of which everyone is facing the issue while installing ERPNext using the shell script

In case users want to use ERPNext with Ubuntu 16.04 then they will have to do manual installation of MariaDB as follows,

sudo apt-get install software-properties-common
sudo apt-key adv --recv-keys --keyserver hkp:// 0xF1656F24C74CD1D8
sudo add-apt-repository 'deb [arch=amd64,i386] xenial main'

sudo apt-get update
sudo apt-get install mysql-common mariadb-common libmysqlclient18 libmariadbclient18 mariadb-client-core-10.0 mariadb-client-10.0 mariadb-server-core-10.0 mariadb-server-10.0 libmariadbclient-dev mariadb-server

After that set a root password.

This needs to be done before running

To Install bench run following command,
sudo bash --mysql-root-password <sql_root_pass> --setup-production

The above is a workaround, I’d recommend waiting for the new installer. If your computer explodes, I am not liable :smiley:

Thank you

Sadly the workaround hits a wall when the install script tries to install wkhtmltopdf for xenial which doesn’t exist at the URL that the script calls.

I had to also install npm manually before running the script and changing the install wkhtmltopdf part in the script so it would install trusty version to xenial also.

And even if you do that you will end up here: Adding Ubuntu 16.04 Support - #12 by koshish

Yeah, well. I’m done with trying to install it on Xenial. Will install on Ubuntu 14 now and upgrade to Ubuntu 16 later then.

Any timeframe planned for the ubuntu 16.04 support script release, the ubuntu installation on trusty (14) was also failing when i checked Bench install failure on Ubuntu Trusty. Currently running it on a VM box using the VM image available. But would like to move this instance to the ubuntu box and a timeframe would help in planning this.

Hey guys, 16.04 support is very close : Setup ERPNext Production site using Ansible by shreyasp · Pull Request #222 · frappe/bench · GitHub

It’s taking time as we’re not just adding support for 16.04 but also adding a lot of other features and fixes along, so hang on :slight_smile:

@shreyasp your workaround just made my day…


Hi there, followed this workaround,
How do you set a root password?

Hi @roblin

The current installer supports Ubuntu 16.04; you need not use the workaround. But, since you have already done it you can set the MySQL root password using the following command,

mysqladmin -u root password <root_password> [Assumption: You haven't specified the root password]

You need to execute this command with superuser privileges

Hi @shreyasp, thank you for the response. I had similar database error on 14.04 . The error might be related to the fact that my vps installed mysql by default. After removed the default mysql, managed to get it installed. I’ll try to install it on 16.04 later. Cheers.