After creating a custom doctype, it is not visible in code base folder

after creating a custom doctype, it is not visible in code base folder

Hi @keerthi_kuttan:

  1. Are you logged as “administrator” user?
  2. developer_mode is set to 1?
  3. Uncheck “Custom” on your doctype

Create your doctype again.
Hope this helps.

System Manager role is selected to my account. Also I can’t uncheck the “Custom” option also. It is disabled. How can I create administrator account?

Hi @keerthi_kuttan,
You need to enable developer mode…

bench set-config -g developer_mode 1

For more details, Click Here

its done. but no change.

Getting error PermissionError: [Errno 13] Permission denied on clear cache

Hi @keerthi_kuttan:

Your need to login with ‘administrator’ … this user is created automatically at install time.
Hope this helps.

bench --site {your site} clear-cache

Try this

I logged in with a user which is created automatically at install time. Created a doctype and saved. Developer mode is set. Still I can’t see any folder for new doctype. May be I am looking in wrong location. Where can I see this. Please help.

Hi @keerthi_kuttan:

But is user called “administrator”? If not, “Custom” check on your doctype won’t be “unclickable” …

Your doctype folder should be located on

yourbench/apps/yourapp/yourapp/yourapp/doctype/yourdoctype

If the doctype was created before, try to create it again.
Hope this helps.

Speaking of which, could you please elaborate on what (custom) means here?

HI @ahassoun:

Are you talking about “Custom” check ? Or “custom” doctype? :yum:

“Custom” check on doctype means in this case … “store it on database”, so you need to unclick it.

1 Like

Go to the site_config.json file in your site directory and add (if it doesn’t exist already)
developer_mode:1;
The above should be added via the command

Then stop the bench (Ctrl+c) and start it again.
You should see the red intro on going into the detail of any doctype in the doctype list.

This will let you remove the “custom” check box (if you’re in the super administrator login. Not the one you created on setup wizard, but the one you created initially on bench new-site command.)

The user created automatically is user@example.com. I can’t see any user called Administrator.

In the edit of doctype,we can see a “custom” checkbox.

Hi @keerthi_kuttan:

“Administrator” is generated automatically on site creation. Name is always “Administrator”.

Try to login.
If you can’t remember the password, use

bench --site yoursite.local set-admin-password yourpassword

Hope this helps.

I did bitnami installation.
sudo cat /home/bitnami/bitnami_credentials I got credentials. Hope this is administrator, but name is not Administrator. Its name is “UserName LastName”

Hi @keerthi_kuttan:

Administrator user is not visible from other user session … I don’t know if Bitnami installation delete it somehow, but probably is still there, and name remains as “Administrator”. Try to login or restore the password.