After downloading template with data uploading corrected data produces unexpected errors

Hi I have been importing data to setup a new ERPNEXT company from the online login and want to update the “Maintain Stock” fields I previously created. I downloaded the “Item” template with data and deleted all of the columns except “Id Name” and “Maintain Stock” then I corrected the Maintain Stock Column and uploaded the new file but I got several messages like,

"Error for row (#21) “3J555C” : {“message” “row #1: Please set reorder quantity”, “indicator”: “red”}


could not find Brand: Mututal Dropcloth Co - 415

But all the Brands shown in the error messages actually do exist in the Brand list and why would I need to correct the reorder quantity if I did not change it?

Thank you


Would you mind sharing the file here with some sample data. We will try replicating it in test account.

Do you want the downloaded template with data and the file I want to upload? And how do I send them to you?

I tried to attach the file on the reply to your email but I did not show up in the forum.
Thank you

New United Distributing Co. Inc. 6917 Carnegie Ave. Cleveland Ohio 44103 800-800-7343 Fax 216-881-4073

I got a similar error last week when I was testing on my local server. In my case I had deleted one column that is actually mandatory in the ITEM csv file. You can find out which columns are mandatory by clicking on the mandatory button before you download the template. Any columns that you find in the template after that will have to be there when you upload data. I think it errors when it doesn’t see all of the mandatory columns on an upload. Well, at least that is what I ran into. Good luck.


Thank you for your response.
That did not work either. I downloaded the Item template with all columns and only changed the data in the “Maintain Stock” column. I did not resort anything. The only other change was cutting off the data at row 3799 instead of keeping all 7000. Then I uploaded it. The error code relating to the “Reorder Qty” column disappeared and a new error showed. “Item code is mandatory because item is not automatically numbered”. The other error remains. “Cannot find Brand…”. One other thing I notice about the downloads is there are blank rows scattered throughout

I just downloaded the Item template with all fields checked, cut off all but the first few rows of data and made no changes to the data. I saved it as uptest.csv, uploaded it and still got the error messages.

@herb will be great if we can see some sample data to replicate this.

Anything you want, please explain what and how. I replied to an email sent to me with an attachment but it did not seem to attach. Try these Dropbox links. For first part of data. Dropbox - File Deleted
for second part of data. Dropbox - File Deleted

Did you get the sample data for the upload? I tried other uploads today and they were also unsuccessful.

This problem has not been solved so I have not been able to go any farther with the data migration from my current ERP and setup this one. Are there any ideas about what is causing these errors? I really want to continue with this soon.

1 Like


Just tried importing Item in my test account on these lines. Worked fine for me.

"Error for row (#21) “3J555C” : {“message” “row #1: Please set reorder quantity”, “indicator”: “red”}

Please try with positive value for re-order qty, thought it should work without that as well.

could not find Brand: Mututal Dropcloth Co - 415

Please re-check Brand value in the CSV file. And extra space ahead of Brand could also be an issue.

I have a few questions for you because I do not think you understand the problem I am having.
I tried to find this item “Water” that you show in the screen shot in my file but could not. Did you create this new item? What document is this screen shot showing? I am not familiar with it.
Do you see a negative value for re-order qty in my data because I only see 0 and 1?
I do not see an extra space ahead of Brand do you or are you suggesting I may have it somewhere? I cannot find it in my data.
Did you try to edit any of the data you downloaded with another download? I can’t. This is my problem. I think the data is ok but something with the software is corrupted. If I click on the Brand Field for any item I get a message with several lines of data and a request to report the issue which I have done several times. Sometimes it just freezes indefinitely instead.