After restoring backup successfully, i am not able to migrate sites nor opening

App Versions
“erpnext”: “10.1.48”,
“frappe”: “10.1.45”

Error Report
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 62, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 22, in handle
data = execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 53, in execute_cmd
return, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 939, in call
return fn(*args, **newargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/desk/”, line 32, in getpage
doc = get(page)
File “/home/frappe/frappe-bench/apps/frappe/frappe/desk/”, line 15, in get
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/page/”, line 137, in load_assets
template = frappe.render_template(template, context)
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 69, in render_template
return get_jenv().from_string(template).render(context)
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 12, in get_jenv
jenv = Environment(loader = get_jloader(),
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 184, in get_jloader
(app, PackageLoader(app, “.”)) for app in apps
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 184, in
(app, PackageLoader(app, “.”)) for app in apps
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/jinja2/”, line 224, in init
provider = get_provider(package_name)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/pkg_resources/”, line 356, in get_provider
ImportError: No module named fullsize
Request Data
“type”: “POST”,
“args”: {
“name”: “modules_setup”,
“cmd”: “frappe.desk.desk_page.getpage”
“freeze”: true,
“url”: “/”
Response JSON

Is this a custom doctype?

Thaks fot your replay,

Actull i dont no much about custom doc type, but i was installed one mode from this link GitHub - libracore/FullSize: This ERPNext App allows you to choose between normal and full-size view.
Right now i am not using this module and I dont want t use this module any further.

I recommend removing the app, and then running an update

1 Like

Once again thanks for your instance replay.

I tried to uninstall but it shows below error message.

Executing Command:
bench --site CRAFTVED uninstall-app fullsize --yes

Backing up…
Traceback (most recent call last):
File “/usr/lib/python2.7/”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/”, line 72, in _run_code
exec code in run_globals
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 94, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/”, line 18, in main
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/”, line 330, in uninstall
remove_app(app, dry_run, yes)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 192, in remove_app
for module_name in frappe.get_module_list(app_name):
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 746, in get_module_list
return get_file_items(os.path.join(os.path.dirname(get_module(app_name).file), “modules.txt”))
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 704, in get_module
return importlib.import_module(modulename)
File “/usr/lib/python2.7/importlib/”, line 37, in import_module
ImportError: No module named fullsize

The operation took 4.20887088776 seconds

This might help (I don’t know very much about custom apps)

hi, i tried all command .

but not resolved.

Did you uninstalled first??

bench --site sitename uninstall-app civil_contracting

yes i tried …

then try to bench update and migrate.

I don’t think this is a recommended route, but it might work… run this and see if the module name is contained in this file…

cat /home/frappe/frappe-bench/apps/frappe/frappe/modules.txt | grep fullsize

If it is, maybe deleting it or commenting it in that file before running the bench update/migrate will work?

i checked it is not present in modules.txt.

tried not working

bench remove-from-installed-apps fullsize
bench migrate


try to clone (using bench get-app or git clone command) GitHub - libracore/FullSize: This ERPNext App allows you to choose between normal and full-size view the app and install it.

You’re SQL backup files hold all the modules details which you’ve created while making customizations.
Every app name is default module name in erpnext.

so while restoring/reinstalling, bench will only install the frappe or may be erpnext automatically but your custom app, that you’ve to install.

after cloning of custom app then install it using pip install -e ./apps/fullsize --no-cache-dir
and try to run bench migrate again.
It should work.

1 Like

Thankyou to everone .

Finally i resolved this issues.:slight_smile:

Issues is resolved by installing Fullsize app from github.
After installing this app, every thing is working fine. And after that I removed and uninstall fullsize app from site as well as bench.

Issues is now re-solved.

Once Again thanks to every one