After Updating V12 from V11, Having problem like in module nothing is showing

Hi, I am using ERPNEXT in windows with vmware. I am very new to ERPNEXT , I am still exploring ERPNEXT. Before two days, I tried to update v11 to v12. Had lot of troubles and finally reached to V12 desktop. My sample items all there. The problem is it is not showing anything in module.

Then I noticed, My frappe version is 12.3.0 but erpnext version is 11.1.38. I tried to update by searching in forums. But couldnt succeed.

Anyone can help me in solving this…Please

on line 361, remove pre_upgrade from the import line. Will push a fix for the same.

Thanks for your reply. I am very new here. In which file ? Can you please tell me the steps…

in /home/frappe/.bench/bench/, line 361. Replace the whole line with from .utils import update_requirements, update_node_packages, backup_all_sites, patch_sites, build_assets, post_upgrade and delete line 402

Thank you very much for your time and kindness to help. As I was using VMware, I just restored the original and did the below changes.

apps > erpnext > .git > config (command: nano config)
[remote “upstream”]
url = GitHub - frappe/erpnext: Free and Open Source Enterprise Resource Planning (ERP)
fetch = +refs/heads/:refs/remotes/upstream/

Then do:
bench switch-to-branch version-11 frappe erpnext

bench update --patch

from a thread. This solved all my problems.. Thank you very much again.