Allow Dropbox Access - getting 400 error

I’ve seen this error in past posts, but I think some new incompatibility with Dropbox exists. I’m on the latest code. Trying to get Dropbox set up on a new install for another company.

I followed the sames steps that have worked on another installation for a different company. When I get to the “Allow Dropbox Access” step, it takes me to Dropbox to approve/allow access, then I get this:

Here’s the text:

Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 62, in application
response = frappe.api.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 56, in handle
return frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 22, in handle
data = execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 61, in execute_cmd
return, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 1055, in call
return fn(*args, **newargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/”, line 315, in dropbox_auth_finish
token = dropbox_oauth_flow.finish({‘state’: callback.state, ‘code’: callback.code})
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/dropbox/”, line 434, in finish
no_redirect_result = self._finish(code, self.redirect_uri)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/dropbox/”, line 120, in _finish
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/requests/”, line 940, in raise_for_status
raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 400 Client Error: Bad Request for url:

If I go back to the working installation of ERPNext (where Dropbox is working great), and try to do the “Allow Dropbox Access” thing, it fails in the same way. Given Dropbox is working on that installation, and at one point the “Allow Dropbox Access” process worked fine, I’m lead to think something has changed with the way Dropbox deals with the authorization request or maybe I did the Dropbox authorization on the working install some version ago and now the code is broken.

Can someone try this out and see if it works for them? Thanks in advance!