Auto-refresh not working - possible nginx ingress issue

I have a fresh install of frappe/erpnext v15 running in a kubernetes environment. The pages are not auto-refreshing after adding items. I’ve ensured that Auto-Refresh is not disabled in List Settings. I’m guessing that websockets are being interfered with by the upstream (kubernetes) nginx ingress.

I’ve tried adding the following annotations but they have no impact. Does someone have this working?
nginx.ingress.kubernetes.io/proxy-read-timeout: “3600”
nginx.ingress.kubernetes.io/proxy-send-timeout: “3600”

Read more about nginx-ingress and sticky session for socketio here Using multiple nodes | Socket.IO

1 Like

Thanks! That makes sense. I’ve added the following annotations to my ingress. Unfortunately, it hasn’t had an impact on auto-refresh. This is actually a pretty simple deployment, it’s a single-node cluster with a ClusterIP erpnext service. Ingress controller is registry.k8s.io/ingress-nginx/controller:v1.10

nginx.ingress.kubernetes.io/configuration-snippet: |
  set $forwarded_client_ip "";
  if ($http_x_forwarded_for ~ "^([^,]+)") {
    set $forwarded_client_ip $1;
  }
  set $client_ip $remote_addr;
  if ($forwarded_client_ip != "") {
    set $client_ip $forwarded_client_ip;
  }
nginx.ingress.kubernetes.io/upstream-hash-by: "$client_ip"