Backup restore from erpnext cloud to local server [Journey App Missing]

Hello dears,

I am trying to restore backup to my local server from erpnext cloud and its give error journey app missing . please gudie how to fix it.


@gsbaig Have you tried using the --force command?

If you can provide the specific commands and process you attempted with the restore, that might assist in giving a better answer? It sounds like maybe there is a custom app that is missing from your backup.

A few other questions, where answers might help folks provide a good answer for you:

  1. What is the source of the backup? Where did you get the files?
  2. Are you restoring to the same version of ERPNext?
  3. Have you ensured that the site has been created prior to attempting to restore? The database has to be restored to a site.

Hope this helps

1 Like

Yes you are right that that is a custom app. the problem is not in the restoration of backup from one server to any other. This problem is that when i create a backup from the cloud , there is a billing app from erpnext journey that is making problem.

How to take backup with out that app is a problem for me. erpnext people did not make this till now i guess

@gsbaig Thank you for the clarification. Not sure if they provide bench access to your instance? Have you requested support from Frappe? This might be the quickest way to address this.

Did you have any resolution about this? Iā€™m facing the same inconvenient.

no it was problem and support did not help in that. Now i think they have generated backup with out that app


I got the solution for this:

There are two modules that are only available in ERPNext Cloud but when you backup they are included to be initialized, so we need to remove it with a bench command or directly from the backed up database.

bench remove-from-installed-apps journeys
bench remove-from-installed-apps erpnext_support

And then you are done.


This worked magically however add site

bench --site {site_name} remove-from-installed-apps journeys