Batch is removed from Serial Number

Hello, I am facing a bug, I am currently using serialized inventory for manufacturing, I can perfectly work with the serial number but the batch number is giving me weird issues, I have an item which has a serial no and batch number,

It was automatically generated from the Purchase receipt, Yesterday i was trying to transfer stocks i had to ammend the stock entry now i dont now know the batch number is removed from the serial and no when i am trying to move the items it says no batch found,

if i do this after removing batch

1 Like

I have the same issue. Any solution for this?

How you got this issue? did you tried to do STOCK ISSUE ?

I have to modify in database directly, and in some case, it lost batch.
I don’t know what is the root cause of this.
I made me can not issue or delivery because the error" the serial…does not belong …batch"

can you tell me how you modified in database?
i solved the issue of delivery.

Generally it is an SQL command on MariaDB prompt like: