Bench command not working

Erpnext is working fine. However, when i try to run some bench command it shows that no such file or directory found. Now I am afraid that if i reboot the system, the erpnext will stop working. I have 3 instances of erpnext running in that production server.

frappe-bench]# bench build
-bash: /usr/bin/bench: No such file or directory

Please, advise how to tackle this issue.

Koshish Koirala

Seems you have not install some new dependency package, run command “bench setup requirements” and then check

still the same issue.

frappe-bench# bench setup requirements
-bash: /usr/bin/bench: No such file or directory

It is not detecting bench command at all. i have 3 different instances of bench. and in all of the instances, any of the bench commands not working.


Have you did any changes recently? Is it working before? Did you install those instances using virtualenv?

Yes, it was working fine before.

  • In 4th instance of bench, I pull the changes in erpnext from git repo, it was having some conflicts, after fixing them, i wanted to bench migrate. It didn’t work.
    -then, I ran “pip install --user -e bench-repo”
  • still it didn’t work
  • i checked in other instances, then i found that, there too it’s bench command is not working

I am creating seperate folder for each bench-repo, then i am doing init frappe-bench inside different folder. so that I can maintain seperate code for each clients

This was solved after running

pip install --user -e bench-repo” using the frappe user.

Earlier I tried using root user , so didn’t work.