Bench init erpnext - error: Warn: command not being executed in bench directory

can’t be able to run the following command.

error: Warn: command not being executed in bench directory

command: bench init erpnext

Are you running the command from the same directory where you have the bench folder?

yes. I am running from the same directory

I’m getting the same error

Same error here (Ubuntu 18.04, Installation )

which linux distro are you using? and whch is pwd? kindly run the below command


I think that error appears if you run bench command in wrong directory.

You have to run bench commands from frappe-bench directory.

Either bench is not installed or you are running the bench command in the wrong directory

hey @sp9leo @Clinton, that is a warning message. it doesn’t disrupt execution. The only reason it shows is because most bench commands are to be executed in a bench directory.

Can you share screenshots?

i came across this error since i have too today ,
if you type ll , you will see which use own this folder , i saw all files with the right user …
but the folder am inside was owned by other user so i change it by this command
sudo chown -R ahmad:ahmad yourfoldername