Bench install error - pdfkit

Hi all,

I am trying to install erpnext on my ubuntu 16.04 system.
When I ran the command bench init frappe-bench --frappe-branch master
i got the following error

Traceback (most recent call last):
  File "/usr/local/bin/bench", line 9, in <module>
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/home/amalendu/erpnext-newProgress/bench-repo/bench/", line 40, in cli
  File "/usr/local/lib/python2.7/dist-packages/click/", line 716, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 696, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python2.7/dist-packages/click/", line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 534, in invoke
    return callback(*args, **kwargs)
  File "/home/amalendu/erpnext-newProgress/bench-repo/bench/commands/", line 19, in init
    verbose=verbose, clone_from=clone_from)
  File "/home/amalendu/erpnext-newProgress/bench-repo/bench/", line 46, in init
  File "/home/amalendu/erpnext-newProgress/bench-repo/bench/", line 137, in setup_env
    exec_cmd('./env/bin/pip -q install -e git+', cwd=bench_path)
  File "/home/amalendu/erpnext-newProgress/bench-repo/bench/", line 130, in exec_cmd
    raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip -q install -e git+

Can anyone help me please to solve this?

when i run
./env/bin/pip -q install -e git+

i get

Command "/home/amalendu/erpnext-newProgress/frappe-bench/env/bin/python -c "import setuptools, tokenize;__file__='/home/amitha/erpnext-newProgress/frappe-bench/env/src/pdfkit/';f=getattr(tokenize, 'open', open)(__file__);'\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" develop --no-deps" failed with error code 1 in /home/amalendu/erpnext-newProgress/frappe-bench/env/src/pdfkit/

hi @Amalendu
refer this


Hello @sagar

Thanks for the reply

I have already Installed wkhtmltopdf

Still it shows the same error!

latest pull of frappe and try



Yes, I am pulling the latest frappe

Yes this is a bug, I am also encountering this issue. There is a dependency missing. Just pushed a fix to develop, should get committed soon.

Thank you @bohlian