Bench setup nginx breaking nginx

When i run bench setup nginx command it generates a nginx.conf file but then i run sudo systemctl restart nginx and nginx wont start unless i delete the nginx.conf that was generated under frappe-bench/config/nginx.conf

Here is my nginx.conf : upstream frappe-bench-frappe { server fail_timeout=0;}ups -
site_config.json { "db_name": "removedforprotection", "db_password": "removedforprotection", -

Any help would be amazing. Thanks

Updated site_config.json, throws same error with sudo systemctl restart nginx

 "db_name": "removedforsafety",
 "db_password": "removedforsafety",
 "db_type": "mariadb",
 "user_type_doctype_limit": {
  "employee_self_service": 10
 "ssl_certificate": "/etc/nginx/conf.d/ssl/fullchain.cer",
 "ssl_certificate_key": "/etc/nginx/conf.d/ssl/"

error that systemctl status nginx.status gives

erpnext@thetechdev-erp:/srv/bench/frappe-bench$ systemctl status nginx.service
× nginx.service - A high performance web server and a reverse proxy server
     Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2023-03-04 17:09:59 EST; 4min 38s ago
       Docs: man:nginx(8)
    Process: 442968 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
        CPU: 19ms

only happens when nginx loads the nginx.conf from bench

Got it, I had to manually modify the file and add it to Nginx/sites-enabled and named the file ERP.conf and removed the link in conf.d :confused: lol