Bench start error on fedora 36

I get this error when I ran bench start from my bench directory. I on fedora 36 with python3.10.

[hezron@dell-l3580 frappe-bench]$ bench start
ERROR: [Errno 2] No such file or directory
Traceback (most recent call last):
File “/home/hezron/.local/bin/bench”, line 8, in
File “/home/hezron/.local/lib/python3.10/site-packages/bench/”, line 127, in cli
File “/usr/lib/python3.10/site-packages/click/”, line 1128, in call
return self.main(*args, **kwargs)
File “/usr/lib/python3.10/site-packages/click/”, line 1053, in main
rv = self.invoke(ctx)
File “/usr/lib/python3.10/site-packages/click/”, line 1659, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/lib/python3.10/site-packages/click/”, line 1395, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/lib/python3.10/site-packages/click/”, line 754, in invoke
return __callback(*args, **kwargs)
File “/home/hezron/.local/lib/python3.10/site-packages/bench/commands/”, line 22, in start
File “/home/hezron/.local/lib/python3.10/site-packages/bench/utils/”, line 160, in start
os.execv(program, command)
FileNotFoundError: [Errno 2] No such file or directory

I cant help here, but could you explain how you installed python on fedora 36?
I tried, but I Fedora dnf could not find the packages needed to be installed.