Bench Start Error on new installation

Hello All,

I installed fresh setup in ubuntu 14.04 getting following error on bench start.
Wrote js/item-dashboard.min.js - 7.97 KB 15:44:03 watch.1 | events.js:160 15:44:03 watch.1 | throw er; // Unhandled 'error' event 15:44:03 watch.1 | ^ 15:44:03 watch.1 | 15:44:03 watch.1 | Error: watch /home/bhagya/Work/Carat55/frappe-bench/apps/frappe/frappe/public/less ENOSPC 15:44:03 watch.1 | at exports._errnoException (util.js:1018:11) 15:44:03 watch.1 | at FSWatcher.start (fs.js:1443:19) 15:44:03 watch.1 | at (fs.js:1470:11) 15:44:03 watch.1 | at createFsWatchInstance (/home/bhagya/Work/Carat55/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:37:15) 15:44:03 watch.1 | at setFsWatchListener (/home/bhagya/Work/Carat55/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:80:15) 15:44:03 watch.1 | at FSWatcher.NodeFsHandler._watchWithNodeFs (/home/bhagya/Work/Carat55/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:228:14) 15:44:03 watch.1 | at FSWatcher.NodeFsHandler._handleDir (/home/bhagya/Work/Carat55/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:407:19) 15:44:03 watch.1 | at FSWatcher.<anonymous> (/home/bhagya/Work/Carat55/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:455:19) 15:44:03 watch.1 | at FSWatcher.<anonymous> (/home/bhagya/Work/Carat55/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:460:16) 15:44:03 watch.1 | at FSReqWrap.oncomplete (fs.js:123:15) 15:44:03 system | watch.1 stopped (rc=0)

Anyone can help me to solve this ??

I tried Following command:-
npm install babel-core less chokidar babel-preset-es2015 babel-preset-es2016 babel-preset-es2017 babel-preset-babili

You might made some change in event.js at line 160.
Please check that and also make sure your nodejs version is atleast 6.x.

just execute this.
echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p

its a problem on linux with node.js


Hello @MCD-50

I didnt made any changes in event.js. I directlly git clone from github repo and installed.
Thanks for the solution its worked for me.