Bench start - error on new installation

Getting the following error when setting up a fresh installation of erpnext. What is the problem and the solution for this?


It may help to say the method of installation, the host environment and dependent package versions.

Ubuntu 20.04, manual installation, and I am using the following doc to make the installation

D-codE-Hub/ERPNext-installation-Guide: The complete guide to install ERPNext in your Ubuntu system (

When I execute “bench start” I am getting this error


bench setup requirements
bench setup redis
bench build

The above 3 steps were successful. However, on executing bench start, the same error reoccured


bench setup socketio
bench setup supervisor

What url does redis-cli prompt show?

May I know where or how I can check the redis-cli URL?

in a terminal: redis-cli

it should look like:>>

Yup this is the one that is being shown

Does bench setup nginx complete?

What does: cat /etc/hosts return?

No nginx setup is not done.

cat /etc/hosts localhost.localdomain

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


sudo pip3 install frappe-bench --upgrade

then cd frappe-bench and bench start again

the output of bench show-config may be useful

still the same error. No change.

I have not setup any site yet, I am not able to proceed to that step. Hence there are no sites

Try changing localhost.localdomain to simply localhost in /etc/hosts

Somewhat similar to this post: