Bench start got stuck

Hello Igrekus, Thanks for your reply.
I tried sudo netstat -plnt but still I get the same no command error.
I tried accessing localhost:8000, but can not load too.
What shall I run now?

What does this give you?

cd ~/frappe-bench
sudo systemctl status supervisor

Hello Trentmu, thanks for your reply.
This is the output of ‘sudo systemctl status supervisor’:
ctl status supervisor
● supervisor.service
Loaded: masked (/dev/null; bad)
Active: inactive (dead)

The supervisor process has exited/ended - restart it with this

sudo systemctl restart supervisor

I got this output for ‘sudo systemctl restart supervisor’:
Failed to restart supervisor.service: Unit supervisor.service is masked.

Hello trentmu,
-I installed the supervisor
-ran ‘sudo systemctl restart supervisor’
-then ran ‘sudo systemctl status supervisor’ again
and got this output :
● supervisor.service - Supervisor process control system for UNIX
Loaded: loaded (/lib/systemd/system/supervisor.service; enabled; vendor prese
Active: active (running) since Mon 2019-04-08 15:02:10 EET; 53s ago
Process: 8950 ExecStop=/usr/bin/supervisorctl $OPTIONS shutdown (code=exited,
Main PID: 8951 (supervisord)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/supervisor.service
└─8951 /usr/bin/python /usr/bin/supervisord -n -c /etc/supervisor/sup

Apr 08 15:02:10 hagar-HP-OMEN-Notebook-PC-15 systemd[1]: Started Supervisor proc
Apr 08 15:02:10 hagar-HP-OMEN-Notebook-PC-15 supervisord[8951]: 2019-04-08 15:02
Apr 08 15:02:10 hagar-HP-OMEN-Notebook-PC-15 supervisord[8951]: 2019-04-08 15:02
Apr 08 15:02:10 hagar-HP-OMEN-Notebook-PC-15 supervisord[8951]: 2019-04-08 15:02
Apr 08 15:02:10 hagar-HP-OMEN-Notebook-PC-15 supervisord[8951]: 2019-04-08 15:02
Apr 08 15:02:10 hagar-HP-OMEN-Notebook-PC-15 supervisord[8951]: 2019-04-08 15:02
lines 1-16/16 (END)

OK - that should be better. Now try your other commands

Hi trentmu,
I tried bench start but got stuck again. I do not know why when this line
‘15:17:51 watch.1 | Rebuilding modules.min.js’
is reached, the command just gets stuck .

I reread your original post - and saw the ports that are assigned both have the extra 1 (normally they are 8000 and 9000) - which implies that a 2nd copy of the system is already running but on different ports. I recommend that you restart the machine or VM

Just restart the vm? btw I m using ubuntu but not on vm.
What do I do now?

If you are in GUI mode, you can use the bottom left “start button”, otherwise in a terminal, run

sudo reboot


sudo shutdown -r now

Ok I will reboot ubuntu, and then run bench start again?

If you installed production mode, then it should start by itself. If you did development, you need to run bench start

Hello trentmu,
I rebooted ubuntu and ran bench start again, tried, but still can not load.

By default it is port 8000 (not 8001)

Tried port 8000 but still can not load, also bench start is still stuck. Can I try something else?
And why do I always get stuck when line:
16:41:11 watch.1 | Rebuilding modules.min.js
is reached

OK - I don’t think I am being much use here - last thing I can suggest…

bench is not necessarily ‘stuck’
The last logged commands I see in my system after a ‘bench start’ is the rebuilding of those *.js files
(before any connections are made from a browser somewhere)

Here are some tips to help you troubleshoot
try browsing to the IP+port
(mysite1,com will only be resolved on the client if you have a hosts entry for it or it’s published to DNS)

Are the IPs of the client and ERPNext on the same network?
(‘ifconfig’ or ‘ip a’ will tell you the IP on ubuntu, ipconfig from CMD tells you the windows client ip)

Can you ‘ping’ the IP of the ERPNext machine from the client

if netstat isn’t installed on the ERPNext box, you may want to ‘sudo apt-get install net-tools’ - it will help you look for port conflicts
before running bench look at the output of ‘netstat -plnt’ and look for a preexisting connection on 8000

Is ERPNext on a VM or a bare machine?
If VM which one - VMWare and VirualBox handle network setup differently - the basic network must be functioning in whatever environment you are using

What about software firewalls?
Ubuntu uses ufw - you MAY need to open the port that the browser needs from there

Hopefully these things will give you a ‘toe hold’ on your troubleshooting

Hello mattlongfield, thanks for your reply.
I tried browsing but still can not access.

This is the output for ‘ip a’:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 5c:c5:d4:86:85:e9 brd ff:ff:ff:ff:ff:ff
inet brd scope global dynamic noprefixroute wlo1
valid_lft 81252sec preferred_lft 81252sec
inet6 fe80::92e5:2a42:a579:4125/64 scope link noprefixroute
valid_lft forever preferred_lft forever

Ubuntu is not on vm

Can you help please?

The problem is solved now, I just had to type the site as localhost:8001 not

Thanks very much.