Bench start never run till the end

I run bench start but it doesn’t complete.
even i run bench setup procfile and bench start again still the same

PS: Can anyone teach me how to install erpnext properly?
my steps:

  1. dl and install virtual box
  2. dl and import both production.ova and development.ova
  3. login as frappe in both production and development
  4. but when i go to https://8080 it is not working.
  5. run the following command in production
    - wget
    - sudo bash --setup-production
    - cd frappe-bench
    - bench start
    it able to complete but still not able to access http://8080
  6. run the following command in development
    - wget
    - python --develop
    - cd frappe-bench
    - bench start
    it will stuck as the above pic

Am i miss out any step? i am really no idea how already, keep try to setup erpnext almost 2 days already and still unable to reach.

Hey @Ying_Rui_Wong, sorry you’re having troubles with setting up.
You’re actually using multiple install methods on the same thing! Also, when you run bench start it is not supposed to end. It is meant to stay like that and keep going.

Let’s take this from the start, do you want to use ERPNext for development or production? (Production means normal use)

Thanks for reply.

I want to use for development.
I thought production(like preview what i have done to my website) is needed after develop.

Even in your development setup you can see what changes you have made. Let’s do this, make a new VM from the ERPNext-Dev.ova file.

Go into frappe-bench in that VM and run bench start

See if you can access the site by putting ‘localhost:8000’ in your browser.

This is my terminal after bench start:

I try to access"http://localhost:8000/" or “http://localhost:9000/” or “
And even try to set the proxy under preference in vm to http://localhost & 8080
but it give me “This site can’t be reached”

I am using xampp & python2.7 in my windows
Do i need to change any configuration?


Hmm, change your network adapter from NAT to Bridged in your VM settings. Then you can check the IP of your VM by running ifconfig and try to access that from your Windows. You’ll need to be connected to a network for this to work.



I wonder is that correct.
I change NAT to Bridged Adapter, there are 4 item under name: Qualcomm Atheros, Realtek PCIe GBE Family Controller, Microsoft Virtual Wifi Miniport Adapter. As you can see the bottom of pic1, there always mention Invalid settings detected, even for NAT, this is the problem?
After changed, I try to access,localhost,or my ip add and able to access my xampp home page. but add 8000 then page not found again
Some people also suggest make change in port forwading(under NAT) as pic2, for me also not working