[Bench Update] Desk doesn't show anything

I have updated frappe and erpnext to latest master branch. But I have got to see blank desk without any icons, when i login to site.

I have tried to see sudo supervisorctl status which shows that something wrong with socketio.

Any pointers would be helpful.

Open your browser’s console and check if there is any error.

Nothing in Console but Network tab shows something:

try the following command
bench migrate
bench build
bench clear-cache
bench clear-website-cache


1 Like

bench migrate throws mysql_exception. I have ‘root’ as user for mysql but here how this has got trying to access as ‘administrator’?

_mysql_exceptions.OperationalError: (1045, “Access denied for user ‘administrator’@‘localhost’ (using password: NO)”)

frappe@DBFFS29:~/frappe-bench$ bench migrate
Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 94, in
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 18, in main
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/click/decorators.py”, line 17, in new_func
return f(get_current_context(), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/init.py”, line 24, in _func
ret = f(frappe._dict(ctx.obj), *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/commands/site.py”, line 217, in migrate
migrate(context.verbose, rebuild_website=rebuild_website)
File “/home/frappe/frappe-bench/apps/frappe/frappe/migrate.py”, line 31, in migrate
File “/home/frappe/frappe-bench/apps/frappe/frappe/modules/patch_handler.py”, line 24, in run_all
executed = [p[0] for p in frappe.db.sql(“”“select patch from tabPatch Log”“”)]
File “/home/frappe/frappe-bench/apps/frappe/frappe/database.py”, line 121, in sql
File “/home/frappe/frappe-bench/apps/frappe/frappe/database.py”, line 67, in connect
use_unicode=True, charset=‘utf8mb4’)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/init.py”, line 86, in Connect
return Connection(*args, **kwargs)
File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/connections.py”, line 204, in init
super(Connection, self).init(*args, **kwargs2)
_mysql_exceptions.OperationalError: (1045, “Access denied for user ‘administrator’@‘localhost’ (using password: NO)”)

Seems like problem is with socket.io, can you reinstall socket io and try to do bench restart?

Even tried to reinstall socket.io bench setup socketio but still no luck.
Getting same FATAL error when i do sudo supervisorctl status

frappe@DBFFS29:~/frappe-bench$ sudo supervisorctl status
frappe-bench-redis:frappe-bench-redis-cache RUNNING pid 28531, uptime 0:01:21
frappe-bench-redis:frappe-bench-redis-queue RUNNING pid 28530, uptime 0:01:21
frappe-bench-redis:frappe-bench-redis-socketio RUNNING pid 28532, uptime 0:01:21
frappe-bench-web:frappe-bench-frappe-web RUNNING pid 28528, uptime 0:01:21
frappe-bench-web:frappe-bench-node-socketio FATAL Exited too quickly (process log may have details)
frappe-bench-workers:frappe-bench-frappe-default-worker-0 RUNNING pid 28525, uptime 0:01:21
frappe-bench-workers:frappe-bench-frappe-long-worker-0 RUNNING pid 28526, uptime 0:01:21
frappe-bench-workers:frappe-bench-frappe-schedule RUNNING pid 28524, uptime 0:01:21
frappe-bench-workers:frappe-bench-frappe-short-worker-0 RUNNING pid 28527, uptime 0:01:21

Found an issue about getting Access denied. I forgot to add site_name in currentsite.txt file. Once added site_name bench migrate works. All issues are resolved.

For socketio issue, i have created new bench using bench init and then replace node_modules folder of new bench with old one.