Bench Update Issue - Exit Status 128

Hi there,

First of all my current configuration is:
Manual install of ERPNext
OS: Raspbian Buster
Config: Pi 2 B Board
Current Bench Version: 4.1.0
Current ERPNext Version: 12.5.2
Current Frappe Version: 11.1.44

When I try to run the command: bench update, I get the usually switch-to-bench error message.
When I try to rectify that by running the commands:
bench switch-to-branch version-12
bench switch-to-branch version-12 --upgrade
bench switch-to-branch version-12 frappe erpnext --upgrade

I get the following error Message:

Now inability to update is not the major issue, however after trying to update unsuccessfully multiple times, I gave up on it to finish what I was doing. But, I now get an error message when trying to access ERPNext:


Please help me solve this issue.

The app version variance happened after I tried the bench update. Everything was fine before that and ERPNext was working properly.

I tried to update bench in hopes that the solution of one of my problems would’ve been implemented in the latest version. In the process I broke my install. Now I can’t completely update and ERPNext won’t start due to version variance.


I found the issue.
The issue was the config file was not properly set (IDK why) when I setup ERPNext manually (maybe a bug). When I faced a different issue, I searched the forum and found the advice to edit the config file. I thought that it was the local .gitconfig file. I now know that I was wrong.


Add the following lines the files apps > erpnext> .git > config AND apps > frappe> .git > config :

[branch "version-12"]
        remote = upstream
        merge = refs/heads/version-12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.