Bench Update/Migrate error in_global_search


We tried to restore the data on a production environment from a previous backup. After doing the restore, when the bench migrate was run, we were getting this issue:

mysql exceptions operational error(1048, column in_global_search cannot be null)

I referred to the previous posts on the discussion forum which talks about issuing a command of

Alter Table tabDocType drop column in_global_search…

but when the command is run, it says that this column doesn’t exist. What could be the issue? Any ideas?



In Global Search field was recently added in doctype. You should try to run the bench update command.

Thanks, Makarand

Even the bench update command is getting stuck up and giving this same error.


Have you tried with the “–migrate” option?

what is the command with --migrate? We ran

bench --site sitename migrate

or just

bench migrate

bench update --migrate

Sorry :slight_smile:

Thanks for the response but there is no such command for bench update --migrate. :frowning:

Looks like the bench version and the database version are in a mismatch. Is there a way to go back to the previous version?


I know that, We download previous version like :
But I don’t know how to install it.