Bench Update: unix:///var/run/supervisor.sock no such file

Hi ,

I’m already on V8 and tried doing an update to get the latest patch. It looked like everything went okay till the final part where the error below showed up:

INFO:bench.utils:sudo supervisorctl restart frappe:
unix:///var/run/supervisor.sock no such file

I checked the site and the version number is still the same

Please advise

Kind regards,

Hi @wale

Try below command
Sudo service supervisor restart
and share the output of the command Sudo supervisorctl status

1 Like

Hi @rohit_w

Thanks for your quick response. This should be from the ‘home’ directory, right? Pls confirm

Kind regards,

Run it under home/your_user/

Thanks @rohit_w, please find output below:

frappe-bench-redis:frappe-bench-redis-cache FATAL      Exited too quickly (process log may have details)
frappe-bench-redis:frappe-bench-redis-queue FATAL      Exited too quickly (process log may have details)
frappe-bench-redis:frappe-bench-redis-socketio FATAL      Exited too quickly (process log may have details)
frappe-bench-web:frappe-bench-frappe-web RUNNING    pid 11304, uptime 0:00:01
frappe-bench-web:frappe-bench-node-socketio RUNNING    pid 10190, uptime 0:00:56
frappe-bench-workers:frappe-bench-frappe-default-worker-0 STARTING
frappe-bench-workers:frappe-bench-frappe-long-worker-0 STARTING
frappe-bench-workers:frappe-bench-frappe-schedule RUNNING    pid 10186, uptime 0:00:56
frappe-bench-workers:frappe-bench-frappe-short-worker-0 STARTING

Hi @rohit_w

Trust you’re doing great. Any update regarding the output above?



check this

You won’t regret trying this! I tried a lot to fix this when I try to restart bench using supervisorctl it says unix:///var/run/supervisor.sock refused connection

I solved by adding chmod=0777 to [supervisorctl] like below [supervisorctl] serverurl=unix:///var/run/supervisor.sock chmod=0777

Now it worked for me just to help anyone with this same issue. Thank you