Bug inventory/batch custom report

Hi all,

I’m pretty new to ERPNext, we’re implementing mainly the inventory management module for the moment.
We need to create and send automatically some specific stock reports to a lender.
After creating and saving a custom report based on “Batch-Wise Balance History” reference report (simply tweaking a few columns/data sets), turns out that on execution, columns headers don’t map with the actual data (warehouse column shows weight, balance quantity shows batch number and some other info are simply gone).
Systematic discrepancies appear like a misalignment.
Reloading, logging out/in, clearing cache… none of these change the result.

I may be doing something wrong but so far it looks like a bug to me.
I guess that to reproduce it, it only takes to create a custom report based on “Batch-Wise Balance History”, amending a few columns (v12 & 13). It works as long as you stay on the initial screen but if you leave the report and get back to it, the issue appears.

Any ideas to share pls?

Did you export to excel?

Thanks for your reaction. I tried exporting to excel and I get the same wrong data.
Have you been able to reproduce the issue on your end?

I just fixed an excel misalignment bug and it has been merged into the develop code at github.
Can you show some screen shots of what you mean?

Here’s above the custom report with wrong data / misalignment (Test batch report)

This one is the original / standard report with correct data (Batch-Wise Balance History)

I guess the issue is similar to the one you corrected. I confirm that on excel, the export gives exactly the same info as on the App (same wrong misaligned data for the custom report and correct data for the standard report).

Do you manage to reproduce this issue?

I have not tried your custom report. This may be a bug.

1 Like

Thanks for your feedback.

Indeed, if you customise the standard “Batch-Wise Balance History” report, you get the misalignment. It just takes to change the columns from the standard report and save the new layout into a new report. Once you get back to this report the data are wrong.

Which steps shall we take to raise the issue?

Thanks for your input Joseph. Would you or any other expert mind looking into this or guide me to potential next steps pls?
I think it’s in the interest of the community given this bug relates to a pretty basic feature of the software.:slightly_smiling_face:

For information I’ve just created an issue on Github, here’s the link:

This bug has been solved. I haven’t checked this feature for a long time, I’ve just tried to reproduce the bug and now it behaves properly. I imagine the solution came in one of the last releases (currently using v13.13).