[bug] "You do not have enough permissions to access this resource"

Hi @vrms

I have same this error, you have solution? pls share thanks

sorry, did not follow up on this specific issue which occured at some point testing stuff.
But, as you seem to run into the same problem 1 year later, there must be others with similar issues and hopefully a solution somewhere?

1 Like

the similar issue on creating item variant.
You do not have enough permissions to access this resource. Please contact your manager to get access.

From the last update ERPNext: v10.1.72 (master) / Frappe Framework: v10.1.64 (master)
when i Make variant from a template I get:

You do not have enough permissions to access this resource. Please contact your manager to get access.

1 Like

I’m getting the same error after updating and I was logged in as Administrator. It was working fine before doing a bench update. I’ve tried to reset the permissions but that doesn’t seem to help.

I noticed the same problem.

1 Like

I’m also running into this, latest V10.

Also have this issue. Running on a hosted version. Would appreciate a rapid solution.

we have the same problem here :egypt: we just upgraded yesterday , any solutions please ??

@AzizPlast it seems you have accidentally flagged one of the posts in this topic .

can you kindly unflag it if my assupmption (that this was done by accident) is true?

it is weird. Even though I brought this up I forgot about it completely. and have managed to create Variants for a while. Just checking again I get the same error on v10.1.73.

As v11 is around the corner I believe and this is not too pressing for me right now I’ll leave it for the moment. @AzizPlast @cpurbaugh, … I’d post an issue on github for this

with v10.1.64 , was that happening too ??

Up to v10.1.70 I was able to make variants.

Same Here !

This has been fixed.

nice !

Just for my understanding … I’ve noted the fix was merged into the hotfix branch (which is the standard procedure I think). Before that then actually takes effect on a productions site the hotfix bracnh now still needs to be merged into master, right?

I do not think this has been corrected in the master branch as yet.

It does not appear to be implemented yet. When can we expect this to be implemented and working in the hosted solution?

Hi. Any update on when we can see a fix for this? We need to create item variants ASAP.

I have been facing this issue for a while on localhosted server. i am not sure whats the issue is. it works file on my local LAN network but this error starts when i shift the server on public IP. and this error occurs every minute even on the home page or in idle condition. first i checked changing the IP pool, disabling antivirus and firewall but nothing worked for me. it only works fine on internal LAN network.

ERP version is

ERPNext: v12.2.2 (version-12)

Frappe Framework: v12.0.20 (version-12)