Can I restore database from version 13.16.0 to version 13.34.1

Dear Sir,

we reinstall our erpnext recently and our version was 13.16.0 when we took a backup,

now it was an opportunity to upgrade to the 13.34.1, we restore the database but the erpnext crashed.

is it ok to restore the database or should we install the previous version and restore then migrate.


in the new cluster setup I see erpnext-conf-bench pod, can i use this pod to through bench command. as I can’t exce the pod.

the backup we have is the database backup.

not the backup from the web ui, we simply dump the database.

is it ok to restore this data to the database and go. I was reading and saw the web ui have a backup tool, but we didn’t use it.

after I resolve this I well attend the erpnext school. promise.

we have those pods in our cluster, can I copy our backup file inside one pods and through bench command to force restore the database.












any pod will do ??
I tried (erpnext-conf-bench) and couldn’t exce inside the pod, any idea I’ll be grateful.


I take the risk and copied the sql backup file into the schedular pod and exce into the pod and through the bench command:

bench --site --force restore dump-202206220447.sql

the process succeeded and return the site successfully restored, but the website is down now.

did I miss something, should I through another command to start the website.

what should I do.

now its urgent the website is down.

the website shows this message

Internal Server Error

is this related to the bench command or is the pod need to be rebuild.

any update would be appreciated.

for the benefit,

I solved this case after restoring the database, run the kubectl apply -f (migrate.yaml), your own version of yaml file.