Can not access Erpnext from browser after install in Azure

Hi guys
I recently installed ERPNext on an Ubuntu 16 VM in Azure according to the following steps : Home · frappe/frappe Wiki · GitHub

I then started bench. Unfortunately when I access the ip associated with my azure ip as given by azure, I can’t access the site. What am I missing?

Is there any firewall? Does port 80 is open publicly?

Yeah I think it is open.Yes I opened up the networking tab in azure, and I think I have it open publicly. Here is a copy of my azure networking settings

I can privately give you ssh access to see the problem via email. I am not sure why it is not accessible. Do you have an email where i can send you access to see the backend?

Did you create a site? Execute this in the frappe-bench folder:
cat frappe-bench/sites/currentsite.txt

Also are you trying to access the site on http://ip_addr or http://ip_addr:8000 ?
Note, it should be http and not https

Also are you on develop or production ?

When I do nano cat frappe-bench/sites/currentsite.txt, the file is empty. I emptied it as per some instructions I followed. but I think I mitigated this by adding 127. ~ and the ip in etc/hosts . Also I have tried with http://ip_addr:8000, and still no result. By the way I enabled access to port 8000 in azure too. I think i did created a site. Is there a way I can send you ssh access to look at this?Do you have an email I can send or is there a way to DM on the forum?

I presume you haven’t turned on the dns_multitenant option. Execute this in the frappe-bench folder

bench config dns_multitenant on
bench setup nginx

Are you trying to run a production instance or a develop one?
If you are developing, it is highly recommended to install on local machine for easier debugging.

In case of server, please remove the entry from ‘/etc/hosts’. That needs to be done on local system, not in the cloud.

I’m not sure if it’s running production or develop. However, I want it to have the hotels module working. I did

bench config dns_multitenant on
bench setup nginx
I also took out the entry I made in /etc/hosts
and then did bench start and tried to connect without success still

just run

 sudo bench setup production frappe

I ended up just going with the simple install azure has(Microsoft Azure Marketplace). However, I realized it does not have the hotels module in it which is what I really want. How do I get it to have this? I want to be able to have this. Hotel Room How do I add it?

Navigate to #/home/frappe/frappe-bench (or likewise folder if bitnami installed using a docker) and run sudo bench update

The error I get now is “refusing to merge unrelated histories” . I read around that if one were doing it ordinarily, we could just use “–allow-unrelated-histories”. But how do i bypass this if I am doing a bench update?

Hi @Kevintah Were you able to resolve this? if yes, can you please post the solution ?