Can not access self hosted server from Erpnext mobile application

Yes.It is working fine on mobile browser

Are you running on a separate port?

What is the server you have selected for the mobile app?

installed erpnext with


sudo bash --setup-production

on aws.Did’nt do any thing else.

domain name is

I added in select server field and pressed go there is no error message.but not login into server and go button disabled

Is there any possibility to access my server from erpnext android application.erpnext became stuck when i add my domain name in server field

I’ve found that sometimes on my iphone, I’ve had to fully close and open a new instance of the app to be able to use it. Can you try closing it down and trying it again? I’m looking forward to what will happen with mobile use in the future, but this post might provide some insight.

still the same.should i do anything else to use my server from mobile application

We have erpnext in local server and we can’t use erpnext app too , i think it’s not work when erpnext installed in local server .

I was just encountering the same problem. I noticed that I was in a different wi-fi with my phone at the time. I was in a public network which definitely has different firewall setting. Maybe check those on your Router?

It perfectly works in a self hosted environment even trough out public networks… at least with frappe/erpnext master branch and app on android 5.1.1- even via c-named domain.
I never checked with other ports then http and https… please give more information about your setup and errors encountered


I had same issue wih my android phone. They put “” as place holder on server connection screen. I did not able to connect my own server when i follow this placeholder. Then I close the app from task manager and tried it with “”. And it works :slight_smile:

Please just try to type your address with http:// or https:// .


App isn’t working. But you can still access it with browser on your mobile device.

Sorry, I am a newbie trying to understand the options of ERPnext

Can anyone tell me whether it is possible to use the mobile app when self-hosting? I find different opinions in this thread…

Welcome to ERPNext @annalyze

I can confirm access to my self hosted ERPNext v10 instance from my phone that runs Android v6.0.1 Marshmallow

Access is both ERPNext android app v0.0.8 or Chrome browser https port 443.

Just install from Play Store, no setup settings at all, just enter URL and valid login id.

Two factor auth is an option.

Hope this helps

1 Like

@annalyze Frankly, I neither install mobile application nor tell any client to do it when the mobile browser is doing same job as the application. I didn’t find any difference between the application UI and the mobile browser. You can access it from mobile with the same url that is for desktop. Only question would be if the settings are correct to access away from localhost.

1 Like


Check your server firewall. Your server might have blocked your mobile IP from accessing. I believe erpnext requires many connections to the server per client therefore the firewall blockage.

For mobile access typically only two ports need to be open: port 80 for http and 443 for ssl connections (the same ones that need to be open for browser access.) Of course these must be open too on the server and gateway portal.

edit: port 80 need not be open - with 80 turned off (just now to trial test), mobile access ran fine on just port 443.

Port 443/HTTPS is the HTTP protocol over TLS/SSL. Port 80/HTTP is the World Wide Web. Let’s face it, port 80/443 are generally a given for being open on any type of filtering device allowing traffic outbound on your network

@clarkej and @Muzzy thanks a lot! Much appreciated

Make sure the protocol is in the URL (http;// or https://). Works on self-hosted installs.

1 Like

So nobody has an answer for the 500 internal server error in short , unistall the app I guess