Can we get an updated VM on ERPnext site

The VM that can be downloaded from ERPnext’s site, has a major issue when being updated to v8. Looks like the database is obsolete and it refuses to update breaking the entire system. I know this is a long shot but we can please get a v8 VM loaded there. I use that VM quite often for clients that to quickly try out the product in the own environment, but it sucks they can’t get all the features even if they update.


If I may make a suggestion, why don’t you create an updated version of the VM and simply export it to use for your clients, this way you can maintain the VM as per your requirements. I did the same thing for my own use and it works fine.


I have tried to do a full install of the bench but I always seem to fail. I will re-attempt it to see if it succeed.

Which parts is it failing, am sure it can be resolved. Please provide a trace or the issues you have encountered.

Will do on my next attempt, I will post any errors that I get.

So I have fully set up a VM and v8 main issue that I have seen it’s that the setup wizard crashes and doesn’t want to finish. I read in the forums which to go past this problem one must “Bench reinstall”. Doing that now, will update you with the results.

At the end part of the Setup Wizard do the following

Uncheck last two options on item setup wizard :

  1. Add a few sample code
  2. setup simple website for my organization

I always do, I am waiting for the bench to finish reinstall. Once it does I will see the status. Thank you for all your help.

Welcome, glad to help.

OK so the setup wizard has been going at it for like 20mins now. any idea what is getting it stuck like that?

Finally it gave me a request time out error

This is the error I always get.

There was an update in the socketio library yesterday. Please run bench update on your VM. It should fix the issue.

Truly an honor for you to take time and reply to my post. Thank you.

The new updates have fixed the issue, as well for the previous VMs. I have yet to run another setup but I will keep everyone posted on the results.

Thank you.


Ok, so I tried two things, I tried to update both my new app, and one of the previous Production VM,

On my new app, nothing happens after login in and for the previous VM. I get an error stating (2006, ‘MySQL server has gone away’)

Try sudo supervisorctl restart to restart all the services involved cleanly to start with

Did that on both. Nothing.

Once again still got this error

If you are on developer mode, you need to kill the bench (ctrl+c) and start again

Try a full cache clear of the browser too (shift + ctrl + r)

So disable developer mode first then clear cache and try again. ok