Can we get an updated VM on ERPnext site

I always do, I am waiting for the bench to finish reinstall. Once it does I will see the status. Thank you for all your help.

Welcome, glad to help.

OK so the setup wizard has been going at it for like 20mins now. any idea what is getting it stuck like that?

Finally it gave me a request time out error

This is the error I always get.

There was an update in the socketio library yesterday. Please run bench update on your VM. It should fix the issue.

Truly an honor for you to take time and reply to my post. Thank you.

The new updates have fixed the issue, as well for the previous VMs. I have yet to run another setup but I will keep everyone posted on the results.

Thank you.


Ok, so I tried two things, I tried to update both my new app, and one of the previous Production VM,

On my new app, nothing happens after login in and for the previous VM. I get an error stating (2006, ‘MySQL server has gone away’)

Try sudo supervisorctl restart to restart all the services involved cleanly to start with

Did that on both. Nothing.

Once again still got this error

If you are on developer mode, you need to kill the bench (ctrl+c) and start again

Try a full cache clear of the browser too (shift + ctrl + r)

So disable developer mode first then clear cache and try again. ok

Still the same issue. This is crazy. Is there any way you guys can upgrade the VM on the ERPnext site to v8?

I just created a fresh VM with 14.04 and the setup takes a very long time still. I know you guys are super busy, but it’s a huge issue especially if clients already have an existing ERPnext system. I am willing to pay for you guys to update the VM that’s listed on your website, that’s actually working and will set up new sites. The reason is my clients that want to be self-hosted that’s usually what they pick. Plus for some reason it performs much better, runs smoother uses less resources. Please let me know.

@Angel_Marchena I would recommend connecting with a service provider

Edit: VMs are usually not a good way to use ERPNext IMO, best to start a new remote instance at DigitalOcean / Amazon / Google

I’ve experienced the same problems as Angel_Marchena and share his frustrations. I first tried downloading the VM - which is still V7 - and then tried ‘bench update --upgrade’ and it failed. I’ve tried several times - using both the quick install and basic install - and all have failed to complete the startup wizard with the same ‘errors ocurred’ message. Most recently I downloaded the ‘dev’ vm and had the same issues when trying to update (upgrade) to version 8.

I noticed that the date on the dev vm is all the way back in January.

While you are under no obligation to update any of the resources you make available, you make it extremely difficult to evaluate your software from a technical perspective.

Are there plans to update both the production and development vm’s to the current release. I have a potential client in the midst of a badly failing ERP upgrade and would really like to offer ERP next as an alternative but I’ve got a lot of research I need to complete before I can do that.

I installed a new instances on last month:

Hope this helps.

It is v8 by now.

Plese close this subject.