Cannot access ERPNext from site set - Default page of Nginx or Error 521

I followed this article and all the steps worked fine but I can’t access it through the website set. I could access ERPNext through http://serverIp:8000 when running bench start before applying some solutions for NGinx issue, now it doesn’t start and says ports are already in use.

This way, the site set to the ERPnext was opening to Nginx’s default page. But, as suggested in one of the threads here, I removed the default page in Nginx’s folder and now the page opens to Error 521.

How to make it work?


Try bench setup nginx and bench setup firewall and see if they help. or describe the solutions to nginx issue so we can see more about the problem.

No difference. I had to install the ERPNext again as changing the branch messed the whole installation. So, in currently installed one, for production, I’ve tried 7th point of this, this and your solution.

If the methods you have tried have had the same result, then there may be an environmental conflict of some sort. Do you have any other applications running on the nginx server and how is the firewall configured?