Cannot change app icon

I would like to change the application icon that I had made earlier.

I used app_icon = ‘octicon octicon-globe’ that doesn’t work

I changed to
app_icon = “‘octicon octicon-rocket’”
app_color = “‘red’”

Also changed in config/ to
“color”: “‘red’”,
“icon”: “‘octicon octicon-rocket’”,

and ran bench migrate

Am I missing something, or is the octicon-rocket not supported?

I tried to add the same icon like yours using the same method. and nothing worked for me too.
finally, I found one doctype Desktop Icon where I updated icon using MySQL update query and now it’s working, you can also check might solve your problem.

bench mysql
update tabDesktop Icon set icon = ‘octicon octicon-rocket’ where module_name = ‘your_module’ and label=‘Your_label’;

1 Like

Thanks for the tip. Found out that even rocket icon works, but needs to be removed off the ’ (single quotes) around it in the table. Maybe the bench -new-app command should strip those quote before putting it into the database. Will experiment and then update here if required.

Has this problem of leaving single-quotes while inserting into the table rectified?

Another solution is uninstalling and installing app again.