Cannot Login After Fresh Installation of v11

I have ran a set of fresh installation in gcp on Ubuntu 16.04.It failed on the first run of easy setup. I tried the second time and was successfully installed. When I tried to log in ,the login page came up but the user name and password interface failed to show. So no means of logging in. I ran bench build and clear cache. It did not solved the problem. I have search the previous post with no solution. When I ran bench–build, this is the result. Kindly help

Had a similar error a while ago, which got fixed with a pip version change, as in this post

Fred, this sounds like you may have installed v11 on a stand-alone Ubuntu box that does NOT have an internet connection. If this is NOT the case then pardon my interruption. However, if you are trying to run locally without an internet connections, please see this post:

Hope this helps.


@bkm thanks for quick response.I carried out the installation in GCP.I have used ubuntu 14,16 and 18.All gave the same result.They were successfully installed after each failed initially but when i ran it the second time in each of the cases,they installed.Thanks.I will however user a faster internet to see if there is going to be a change .
Any other help is welcome from all

If you would like the install to complete successfully on the first pass, be sure to create the default user account on the server before running the install script, then include the same user account in the --user switch of the install command.

If the install script is run without the account existing already (frappe, or fred, or whatever you use) you will generally fail the first pass on install.

I havce also found that the Ubuntu images in GCP are not necessarily being generated correctly every time. In the past 2 months I have had to restart with fresh OS images more than once becasue something was not right when it was first spun up in my account. At first I thought it was due to a poor internet connection at my location, but came to find in other forums that other GCP users are experiencing the same thing. For me it was most noticed with 18.04 and 16.04 LTS versions. For a while I switched to Debian.

For a while I would spin up 3 Ubuntu servers all at the same time and perform the exact same steps on all three at the same time and 1 or 2 of them would fail. The one that completed is the one that I used. The last time I did that was March 5th. Since that experience I have abandoned GCP until I hear better things about the server stability.

I have several KVM VPS servers that I leased from places listed on so I can continue testing.

That has been my observation. Your mileage may vary…


if that is true. :slight_smile: Can you create a PR adding this info to the “Easy Install” section of the bench’s README ?

@bkm i have used a faster internet.It is the same. I have used this method to create the user sudo python --production --user fred. It has worked fine at other times.Since two days i have been on this without success.
However it complained of when i ran bench update --build.

Any help from any one is welcomed.

yarn seems to be a popular breaking point these days. I have never encountered any problem but saw the term popping up quite often lately there may be a solution in any of those Topics.

@vrms @bkm Thanks for your cares.I followed instruction here Install script and V11 - #38 by antiquark100 to fix the problem.
Thanks all

1 Like