Cannot start ERPNext app

Urgent please,
Please I need your support.
On Digitalocean VPS, I have used ubuntu 18.04
I have used easy install script to ionstall ERPNext.
installation completed successfully but cannot access application below message shown

FYI, below supervisor status

frappe@erptest:~/frappe-bench$ sudo supervisorctl status
frappe-bench-redis:frappe-bench-redis-cache                 RUNNING   pid 10268, uptime 0:14:01
frappe-bench-redis:frappe-bench-redis-queue                 RUNNING   pid 10267, uptime 0:14:01
frappe-bench-redis:frappe-bench-redis-socketio              RUNNING   pid 10273, uptime 0:14:01
frappe-bench-web:frappe-bench-frappe-web                    STARTING
frappe-bench-web:frappe-bench-node-socketio                 RUNNING   pid 10683, uptime 0:11:12
frappe-bench-workers:frappe-bench-frappe-default-worker-0   RUNNING   pid 10669, uptime 0:11:13
frappe-bench-workers:frappe-bench-frappe-long-worker-0      RUNNING   pid 10670, uptime 0:11:13
frappe-bench-workers:frappe-bench-frappe-schedule           RUNNING   pid 10668, uptime 0:11:14
frappe-bench-workers:frappe-bench-frappe-short-worker-0     RUNNING   pid 10671, uptime 0:11:13

Did you try bench restart? Did you receive any error messages?

@rmeyer yes we did bench restart, no error shown

But what did you do before? What configuration do you have?

just we went through easy install steps, by configuration you mean VPS config?

Why is it urgent if it’s a fresh install?

I mean Server / Bench / Sites config. :wink:

Easy install on a Ubuntu Droplet worked seamlessly, the last time i tried.

cd to frappe-bench folder
Then run: ./env/bin/pip install werkzeug==0.16.0

1 Like

Yes, we have a deadline to meet that’s why urgent.

server : VPS on digitalocean
Bench : 1 bench
Sites : 1 site

yes it’s working fine but stuck at frappe-bench-web:frappe-bench-frappe-web service with starting status continuously, supposed to be running?

we have stopped, then started no luck.

bench restart also tried no luck.

thx for your support


issue resolved, thx all for the support.

Confirmed. I just reinstalled Ubuntu 18.04 on two different VPS for testing purposes, following “easy install” suggestions like

Also installed werkzeug==0.16.0
Traceback (most recent call last):
File “/home/frappe/frappe-bench/env/bin/gunicorn”, line 8, in sys.exit(run())
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/”, line 58, in run
WSGIApplication(“%(prog)s [OPTIONS] [APP_MODULE]”).run()
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/”, line 228, in run super().run()
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/”, line 72, in run
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/”, line 58, in __init__self.setup(app)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/”, line 118, in setup
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/”, line 67, in wsgi self.callable = self.load()
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/”, line 49, in load
return self.load_wsgiapp()
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/app/”, line 39, in load_wsgiapp
return util.import_app(self.app_uri)
File “/home/frappe/frappe-bench/env/lib/python3.6/site-packages/gunicorn/”, line 358, in import_app
mod = importlib.import_module(module)
File “/home/frappe/frappe-bench/env/lib/python3.6/importlib/”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 994, in _gcd_import
File “”, line 971, in _find_and_load
File “”, line 955, in _find_and_load_unlocked
File “”, line 665, in _load_unlocked
File “”, line 678, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 13, in
from werkzeug.contrib.profiler import ProfilerMiddleware
ModuleNotFoundError: No module named 'werkzeug.contrib

But cannot access at any VPS

Oops… after installed werkzeug==0.16.0 was something with cache, I finally can access.

This do the trick…

1 Like