Can't access ERPNext with latest release


I’m currently using ERPNext on Google Cloud Platform, every thing worked fine for me until the latest release. (that’s what I think).

I’ve installed ERPNext (previous releases < v6.22.1) on GCP a bunch of times without any issues. Yesterday I tried installing it with the latest release (6.22.1), and when the ERP installs, I cannot access it. With every browser I try to connect to I get an error that says ERR_CONNECTION_REFUSED.

I’m using Ubuntu 14.04 and all the steps are the same with the previous installations. I was wondering if something changed that I might have overlooked.

Thanks for your time.

Can anyone tell me how can I install a previous release of ERPNext?


I don’t think it is the problem of the release, but a problem of bad installation. Connection Refused indicates that your browser isn’t able to connect to the GCP server or the production settings weren’t configured.

Try running bench setup production from the frappe-bench folder. There’s many things that could’ve gone wrong during install, but the installer should’ve shown an error message. You should look for that.


The installer showed no error, and I’ve done this like 50 times, I even have a little “manual guide” on how to do it.

Tried yesterday with AWS, and the outcome was the same.

Anyone knows how can I install an old release of ERPNext?

Try checking out the old release for frappe and ERPNext in the apps folder.

And then run bench --site sitename reinstall

@pdvyas just fixed it in bench. Run bench setup production again and it will start working