Can't access my site from domain name

My domain name is
I can’t access my erpnext website from there, but i can from the local ip.
Please Help


I can access it.

Yes, please let me know how you configured

Please let me know what should I do.

refresh your browser cache and check. if still cant reboot desktop/laptop and check

Tried it. I can access it from public ip, but I can’t access it from my domain name.

Did you update your DNS to point to that domain. It dosn’t seem to resolve to any IP

I found out that that’s my problem, but I don’t know how to do that either. Can you tell me how?

Without knowing your DNS setup and whether you have CLI or web access, I cannot give you the exact instructions but generally what you need is to add a host, in your case ‘erp’ to your domain, ‘’ which should point to the public IP address of your machine that is running ERPnext. I hope this helps.

1 Like

Login to your domain provider settings where you setup your subdomain
Assign to the subdomain the A-Entry with the public IP of your server (which works for you). The changes can take up to 24h.

After that you should be able to read your erp via if it is no multitenant setup.


Thanks a lot!

Hey there, can anyone help me with this !

I have a VM setup on my server running Ubuntu 16 lts on Oracle Virtual Box. I have erpnext setup with dns multitenant on.

I have successfully setup my Erpnext with a domain name accessible from internet. I had pointed the dns from godaddy to my router ip and port forward to ubuntu vm within router. it works fine.

Problem is I am unable to accesss erpnext site within the LAN. it gets routed to my router page if I access it via domain name. Also not accessible via local IP address,( dns multitenant on).

I also tried adding ip address & domain name on /etc/hosts file, no success !

how do i access erpnext website locally ? please help

Hi, We also have a similar issue … while ERP Next is accessible through IP , but not able to access through our Domain

pls suggest workaround pls.

Hi @Bindu_Nanda:

Please, we need more details. There would be a lot of reasons …

First, check if your DNS is pointing to your public IP address

If it works properly, need to check nginx and bench config