Can't add product to cart "Error: Value missing for: Subject "

we have an installation of ERPnext v4 on our server. The webshop is activated, but when someone wants to add a product is to the Cart. It give an error: ‘Error: Value missing for: Subject’

What’s happening? Please help.

Here’s a product example, which could not be added to the cart:;-free-space

@Evaldas_Pabreza nice looking site :smile:

Its best to move to Version 5.

Hi, Thank you.
Does that mean that version 4 did not supported shopping cart at all?
Is it possible to move to version 5 by keeping all the customizations (both ERP an web) that we have done to version 4? Please give me a link to read about it. Thanks!

@Evaldas_Pabreza We are not supporting v4 at the moment, but upgrades are easy and part of the product.

If you have customized via Customize Form or Custom Field then your customizations won’t be lost.

Direct edits to DocTypes will be lost.

Read this for upgrading:

Hi, rmehta,

I have moved to v6 - fresh install on a new server. I have even migrated my data, but the cart still does not work. Now I receive 2 errors:

Error: Value missing for: Subject
Error: Value missing for: Sales Partner

my website is now under

Do you have any ideas why that is?

@Evaldas_Pabreza can you share the full trace?

This error is shown directly in the website when you try to add an item to the cart.
I have already copied everything it shows.

ShalI I check somwhere else, exept the front end?

I have solved one error: Error: Value missing for: Sales Partner
For this I edited my test user in the ERP, by assigning proper Territory and Sales Partner.

Now I don’t know, what means ‘Subject’ in the context of the shopping cart. Could it be that shopping cart module is not properly installed? How do I check that?

Seems funny. Is there an Email Alert linked to this process?

Evaldai, turiu tą pačią bėdą su šviežia instaliacija.
Ar pavyko išspręsti?

Hello rmehta,
One and half years later I decided to try fresh install on a new Ubuntu 14 server. An I receive the same error, when I try to add items to the shopping cart.

The error related to Sales Partner can be solved as i described above by me. But what is this issue with “Subject?”. Now I installed ERPNext v7.2.13

You can try this our by yourself:;-pm-fiber;-matchbox-2

Please help us figure this out. I wonder whether there are any users who really use the e-shop functionality of ERPnext? I would really like to do that on our site too.

Here is a trace of the error you are having (in Chrome, Ctrl-Shift-i brings up the console):

Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 56, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 19, in handle
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 42, in execute_cmd
ret =, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/”, line 900, in call
return fn(*args, **newargs)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/shopping_cart/”, line 91, in update_cart
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 223, in save
return self._save(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 246, in _save
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 190, in insert
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 388, in _validate
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/”, line 608, in _validate_mandatory
MandatoryError: [Quotation, QTN-00004]: subject

Do you have any customization in the Quotation doctype?

No, with this fresh installation I tried not to change any files in the server. I only configure what is accessible from ERPnext interface.

I have an older installation working on a production server and what I understood is that once I change files in the server, it becomes difficult to update to a newrs version afterwards. This is why I don’t touch doctype files in this new testing server.

Finally solved this! Ben thank you very much for gettin me on track.

The problem was that I had a mandatory field in “Quotations” module called “Subject”. Now I unchecked the mandatory checkbox. Then it showed another error that quotation QUO-00004 is duplicate. Then I understood that after importing Quotations from our older system, I have not updated numbers or QUO- naming series. Once I did that, adding to car works like a charm.

Thanks again!