Cant Create new application with bench

I tried this command on my Ubuntu server
bench get-app***

and i got this error app officeplusapp
INFO:bench.utils:git clone //** --depth 1 --origin upstream
fatal: could not create work tree dir ‘officeplusapp’: Permission denied
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/”, line 32, in get_app
get_app(git_url, branch=branch)
File “/home/frappe/.bench/bench/”, line 65, in get_app
cwd=os.path.join(bench_path, ‘apps’))
File “/home/frappe/.bench/bench/”, line 140, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git clone ://**app --depth 1 --origin upstream

I added sudo and the same error also occurred.

Please I need help with this issue. Am sure someone has experienced the same thing also.

Thanks in advance.

bench remove-from-installed-apps appname

and try installing again

Most of the people here are experienced with Github but you are running for bitbucket and the problem is not related to Frappe its purely through Permission issue,do some workaround in google to clear that permission issue

I have tried this but app name is not even registered yet, so that was triggering an error.

I am going to try this option and see how it goes. I will provide feed back.