Can't disable an AutoRepeat Sales Invoice

I have a subscription invoice that I need to stop. I find the Auto Repeat List, open it and click on the “Disabled” checkbox at the top. When I Save the record, I get a popup that says: “Enable Allow Auto Repeat for the doctype Sales Invoice in Customize Form”.

I have looked at the Sales Invoice DocType and Row #174 shows the Options listed as “Auto Repeat”,. so it looks “enabled”. Any thoughts on what I am missing?
ERPNext: v12.4.2
Frappe Framework: v12.2.1

You need to go to Customize Form > select the doctye for which u want to enable/disable the auto repeat feature and check Allow Auto Repeat = true.